COOLING FANS NOT RUNNING

1996 Mercury Sable

Tiny

angegirl

May, 28, 2008 AT 6:56 PM

Engine Mechanical problem
1996 Mercury Sable 6 cyl Front Wheel Drive Automatic

Please help Im at my wits end trying to figure this out. My airconditioning was not working properly, then I noticed the cooling fans were not running. Wht should I do?
Thank you
I would die without u guys.

FOUND 3513 RELATED QUESTIONS

4 Answers

Tiny

mastertechtim

May, 28, 2008 AT 7:26 PM

You need to find out why they arent running. First check the blade and see if you can spin it freely, if it binds when spinning then replace the motor. You can check for power at the fan with a te4st light to see if it gets power when the ac is on. Place test light across the 2 wires at the cooling fan and see if it lights.

Tiny

angegirl

May, 29, 2008 AT 6:26 AM

We checked the fan blades they spinn freely and we hot wired and the fans will run. We replaced the Constant Control Module 2yrs ago because the fans would not quit running. Could this be the same problem? We called the dealer we bought the module from he said they quit selling these. Now what should I do?
Thank you
Angel_girl

Tiny

mastertechtim

May, 29, 2008 AT 11:28 AM

Most likely thats what it is. Ford still sells them, I replace them all the time. If not try a junk yard, they will have it.

Tiny

angegirl

June, 2, 2008 AT 9:23 AM

Thank You Masterechtim! It was what you said, the central control module. They had quit selling the other brand. It was listed as a different thing. Sold by a different company. Praise the Lord, I thought I was going to have to go in debt for a new car.

Please login or register to post a reply.

Air Conditioner Recharge - Simple
Blend Door Actuator Replacement
Cabin Air Filter Replacement Chevrolet Tahoe