97 Mercury Mountaineer fuel pump issue

Tiny
MDIMAURO
  • MEMBER
  • 1997 MERCURY MOUNTAINEER
I have a 97 Mercury Mountaineer. I recently put a new tank and fuel pump in it back in March. A few weeks ago the pump began to squeel loudly. I replaced it today thinking it was defective, and after driving around for an hour the new one began to squeel. I check the fuel pressure and that was normal. Any ideas of what may cause this?
Do you
have the same problem?
Yes
No
Saturday, May 5th, 2007 AT 3:16 PM

2 Replies

Tiny
MDIMAURO
  • MEMBER
The tank was rusted so I replaced the tank. I figured since the truck is 10 years old and has 180,000 miles on it I might as well replace the fuel pump as well. I replaced the filter at the same time. I put new gas in it after I fixed it the first time. The second time I did not drain the tank I just used a transmission jack to get it off. The engine runs fine but sometimes when the pump is making a lot of noise it bogs down like it is not receiving enough fuel. I have been using Delphi fuel pumps. It makes no sense though because the pressure is fine. Thank you for your help.
Was this
answer
helpful?
Yes
No
-1
Saturday, May 5th, 2007 AT 11:46 PM
Tiny
MDIMAURO
  • MEMBER
Today I replaced the second bad fuel pump. Upon doing so I realized the sock on it was in horrible condition. It was being sucked into the pump causing it to work harder. I did pour dry gas in the tank as well to clear up any water if any. Thank you for your help. It is all working fine now.
Was this
answer
helpful?
Yes
No
Sunday, May 6th, 2007 AT 8:15 PM

Please login or register to post a reply.

Recommended Guides