1993 Mercury Marquis White smoke coming from the exhaust

Tiny
EJBAIN
  • MEMBER
  • 1993 MERCURY MARQUIS
  • V8
  • 2WD
  • AUTOMATIC
  • 118,568 MILES
I have a 1993 Grand Marquis with 118,568 miles and it runs good for the miles it got. I notice it use give a little bit of white smoke from the exhaust whenever I started it up but when i drove the car it never gave white smoke. But now it is giving plenty white smoke from the exhaust when I start it up and let it sit for a while. The coolant level is full but I notice sum times the coolant in the coolant tank use to pump the water up the tank when i open at some point whisch makes it to over flow. When i Try open the cap on the coolant tank the water trys to over full quick wit a pressure air sound forcing the coolant back out. I bougth the car with this problem but the guy i bought it from told me it needed the lower raditior hose on the raditior to the water pump to be change because it was the orginally one from 1993 and the other hoses was brand new beside the lower one. Do you think the hose is the cause for this problem?


http://www.2carpros.com/forum/automotive_pictures/177191_031108_1853_1.jpg

Do you
have the same problem?
Yes
No
Wednesday, April 9th, 2008 AT 8:17 PM

1 Reply

Tiny
MHPAUTOS
  • EXPERT
Hi there,

you should have the engine tested for a possible head gasket issue, it may only be minor now, bot it wont get any better. Get it checked before it lets you down.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Wednesday, April 9th, 2008 AT 10:21 PM

Please login or register to post a reply.

Sponsored links