CRANKS BUT WON'T START

1981 Mercedes Benz 300sd

Tiny

hippsakamo

August, 22, 2009 AT 6:15 AM

Engine Mechanical problem
1981 Mercedes Benz 300sd 4 cyl Two Wheel Drive Automatic 200000 miles

I purged the lined with the plunger, no effect. I have noticed that if a disconnect the fuel line in, rifgt at the plastic fuel pre-filter, no fuel is pumped. I do not hear the fuel pump with the key on or when the car cranks. Shoud I hear it? Fuel does seem to pump out of the injector pump though. I suspect the fuel pump. Am I missing anything?

FOUND 50469 RELATED QUESTIONS

3 Answers

Tiny

Jacobandnickolas

August, 22, 2009 AT 9:28 PM

It does sound like the fuel pump is weak or bad. Here is a how to for checking it. Check it out and let me know what you find.

http://www.2carpros.com/how_to/how_to_check_fuel_pressure.htm

Tiny

hippsakamo

August, 23, 2009 AT 6:20 PM

Thanks, where is the fuel pump? CHILTON SAYS IT IS IN LINE, under the left pass floor panal, but I DON'T see it there. Is it in the fuel tank? In line next to the fuel tank?

Tiny

Jacobandnickolas

August, 24, 2009 AT 3:00 PM

I just tried liiking I up with our online repair manual and the info isn't available. I believe the Chilton manual is correct. I don't think it's in the tank on your model.

Please login or register to post a reply.

Crankshaft Position Sensor Replace Chevrolet
Crank Angle Sensor Replacement Mercedes Benz
Fuel Pump Test Chevy Tahoe
Fuel Pump Replacement
Fuel Pump Replacement Done Right
Fuel Pump Pressure Test