1994 Mazda MPV

Tiny
PETE123
  • MEMBER
  • 1994 MAZDA MPV
Transmission problem
1994 Mazda MPV 6 cyl Four Wheel Drive Automatic

On some occasions when I go and start engine it starts right up but when Itry to put shift in drive it does not move and 15amp fuse is blown. When fuse is replaced it is ok till next time. Mechanic took steering columm apart and everything seems ok including solenoid.
appears that this paticular fuse is connected to
several other componets odometer, shifting instrument cluster lights. Does the transmission have any internal
electrical componets that might be blowing fuse

Thanks
Do you
have the same problem?
Yes
No
Friday, June 25th, 2010 AT 5:48 PM

9 Replies

Tiny
KHLOW2008
  • EXPERT
Hi pete123,

Thank you for the donation.

What is the fuse that is blowing? Can you provide the location and description?
Was this
answer
helpful?
Yes
No
+1
Sunday, June 27th, 2010 AT 3:44 PM
Tiny
PETE123
  • MEMBER
Fuse box located interior of vehicle under dash on left side.
Fuse is for meter
Was this
answer
helpful?
Yes
No
Monday, June 28th, 2010 AT 4:45 PM
Tiny
KHLOW2008
  • EXPERT
Our database does not provide the actual description of the fuse so can you please indicate which fuse from the diagram?


http://www.2carpros.com/forum/automotive_pictures/192750_FuseBoxDash94MPVFig02_1.jpg

Was this
answer
helpful?
Yes
No
Tuesday, June 29th, 2010 AT 8:07 AM
Tiny
PETE123
  • MEMBER
The fuse location is letter I I have been using the vehicle the past week and it has not blown. The fuse is labeled meter which controls the instrument cluster and cruise control
Was this
answer
helpful?
Yes
No
-1
Monday, July 5th, 2010 AT 2:39 PM
Tiny
KHLOW2008
  • EXPERT
The fuse powers the followings and any of them could be the cause.

1. Instrument cluster.
2. 4GR off switch
3. Shift Lock Solenoid Valve
4. Door Lock Timer Unit
5. Cruise Control Unit
6. Diagnostic Module

Since the fuse is not blowing now, it would not be possible to locate the source. It could ba a bare wire somewhere causing the problem intermittently.
Was this
answer
helpful?
Yes
No
Monday, July 5th, 2010 AT 4:10 PM
Tiny
PETE123
  • MEMBER
Fuse is blowing more frequently. I now notice that when
you start vehicle and then place automatic shift lever from park to reverse it is blowing the fuse.

I did place lever into neutral then put in a new fuse.
I then place lever into drive and their was no problem.

It seems that only when I shift from park into reverse that it is blowing the fuse
Thanks
Was this
answer
helpful?
Yes
No
Tuesday, July 6th, 2010 AT 6:02 PM
Tiny
KHLOW2008
  • EXPERT
As fuse is only blowing when shifting out of park, the component likely to cause that would be the interlock solenoid valve. Check if the solenoid is clicking onto bare wires that had been caught in between.
Was this
answer
helpful?
Yes
No
Wednesday, July 7th, 2010 AT 8:58 AM
Tiny
WELLGO
  • MEMBER
I'm having a similar problem, however, the fuse blows when I start the engine. Not sure if I should trouble shoot the sensors or the Meters.
1992 Mazda MPV 3.0L V6 RWD. Does the fuse control the same things as this previous post?

Thanks for your help.
Was this
answer
helpful?
Yes
No
+1
Thursday, June 16th, 2011 AT 8:47 PM
Tiny
KHLOW2008
  • EXPERT
Is it the same fuse that is blowing?
Is your vehicle automatic transmission?
Was this
answer
helpful?
Yes
No
+1
Friday, June 17th, 2011 AT 11:40 AM

Please login or register to post a reply.

Recommended Guides