1992 Lincoln Town Car Wiper motor circuit breaker - working

Tiny
RYSKAMP
  • MEMBER
  • 1992 LINCOLN TOWN CAR
Electrical problem
1992 Lincoln Town Car 90000 miles

My wipers stopped in the up position (common problem from the forum). However, when I reached down to check the fuse (turned out it was more of a circuit breaker or relay instead) it was so hot I had to grab it with a napkin so my fingers didn't burn. It is a rectangular metal piece about 1.25 " by.375" by.625" with two tabs set off center extending another.375".

My questions are: 1) the part number D9AB-14526-CA, 8.25 Amp, does not seem to show up anywhere on the web. I called the Ford dealer and they can get one for me. Before I buy it, I wanted to know if you think that will solve my problem or whether I should be replacing the wiper motor instead as suggested throughout the forum. Also, is the high heat a normal failure mode for this type of device? 2) Do you know where I can order the circuit breaker online instead of going through the dealer if it turns out that I do need to replace it? ? 3) Is there an easy way to test to see if this old one is working right or should I just replace it?

Thanks for the help! Jay
Do you
have the same problem?
Yes
No
Monday, May 19th, 2008 AT 12:04 PM

3 Replies

Tiny
MERLIN2021
  • EXPERT
Continuity test it, if it's ok put it back in but first unplug the motor and test the leads for power with the key on and switch in an on position, not intermitt. If you do have power, replace the motor, if no power, check the switch and wires.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 20th, 2008 AT 1:50 PM
Tiny
RYSKAMP
  • MEMBER
Thanks for the advice! The circuit breaker did work fine - I replaced the wiper motor and everything is back to normal! Thanks again!
Was this
answer
helpful?
Yes
No
+1
Tuesday, June 3rd, 2008 AT 7:45 AM
Tiny
MERLIN2021
  • EXPERT
Yep.
Was this
answer
helpful?
Yes
No
+1
Tuesday, June 3rd, 2008 AT 1:38 PM

Please login or register to post a reply.

Recommended Guides