2003 Land Rover Discovery 2 03 Land Rover Discovery ISSUE

Tiny
ROVER RIC
  • MEMBER
  • 2003 LAND ROVER DISCOVERY 2
  • V8
  • 4WD
  • AUTOMATIC
  • 64,000 MILES
2003 Land Rover Discovery: OK- here in Colorado yesterday morning and this morning the temperature fell quite a bit and the lows were in the 40s. I noticed both mornings that my battery was a bit slow and both the Manual Mode and Sport Mode lights were both flashing along with the lights on both sides of the automatic gear shift. My Rover would not shift gears automatically nor could I do it manually. I stopped, turned the engine off, waited a second and started the engine. The lights would not go off BUT after driving it slowly for a few minutes then stopping, turning off the engine and restarting, the lights went off and the transmission works normally. This is the first time this has ever happened. Now, my transmission leaks a small amount - nothing substantial - 64k miles on the Rover. What to do? Please advise? What is the trouble?

Thanks for your help and professional advice. -Ric in Colorado
Do you
have the same problem?
Yes
No
Monday, June 14th, 2010 AT 12:33 PM

1 Reply

Tiny
DAVE H
  • EXPERT
Have the car plugged into a diagnostic computer at the dealer or transmission shop to check for trans related fault codes


https://www.2carpros.com/forum/automotive_pictures/266999_266999_smiley5_8_8.png

Was this
answer
helpful?
Yes
No
-1
Sunday, June 27th, 2010 AT 4:30 AM

Please login or register to post a reply.

Sponsored links