S AND M LIGHTS FLASHING

2001 Land Rover Discovery 2

Tiny

Doe

March, 6, 2009 AT 10:56 AM

Transmission problem
2001 Land Rover Discovery 2 V8 Four Wheel Drive Automatic 200, 40 miles

The s and m mode lights flash. Car runs poorly and cuts off and will not start. After 30 or so minutes it cranks. Battery is new and have cleaned battery connections. Have had car checked to see if alternator is charging and it is. This seems to happen at lower speeds and a clunk noise is heard and the lights begin to flash and then have to get off the road.

FOUND 6122 RELATED QUESTIONS

Light Codes

41 ANSWERS

Lighting Issue

5 ANSWERS
8 IMAGES

2 Answers

Tiny

ROVERTECHGOLD

March, 19, 2009 AT 1:01 PM

THE S AND M LIGHTS ARE MODE LIGHTS FOR THE TRANSMISSION. I WOULD RECOMMEND GETTING THE FAULTS CODES PULLED FOR THE ENGINE AND TRANSMISSION. ONCE YOU HAVE MORE INFO YOU CAN GO FROM THERE.

Tiny

danielsolis

January, 17, 2013 AT 6:43 PM

I have a similar problem with my 2000 v8 discovery 2. I found out that it is in sport mode. I followed directions on a previous site to place in high gear then reverse for 20 ft. I have checked the transmission fluid while running in neutral and is a darker red color but full on fluid. It seems when it heats up it goes into this mode. I have taken in to a full service shop and they could not figure out reason for this but told me it would be the crank sensor. I would really appreciated your suggestions on this. Thank you.

Please login or register to post a reply.

Cabin Air Filter Replacement Chevrolet Tahoe
Instrument Cluster Replacement GMC Yukon