SQUEAKY NOISE WHEN ACCELERATIN

1999 Land Rover Discovery 2

Tiny

hwaire22

January, 19, 2010 AT 12:28 AM

Noises problem
1999 Land Rover Discovery 2 V8 All Wheel Drive Automatic 125000 miles

Whenever I'm at a complete stop and start to accelerate i hear a squeaking noise coming from underneath likes somethings dryed out. It never makes the sound when I'm in neutral or park giving it gas only when i accelerate driving there is also a tiny bit of vibration. I thought it might be the brakes so i change them all out also changed the oil and the transmission still doing it also here is a video link of the sound http://s668.photobucket.com/albums/vv41/hwaire/?action=view&current=1111111001.flv

FOUND 902 RELATED QUESTIONS

4 Answers

Tiny

Dave H

January, 31, 2010 AT 5:52 AM

Check/replace wheel/hub bearings

Tiny

nspain

February, 6, 2010 AT 9:53 AM

I have exactly the same problem (identical sound) and also though it was a dry joint somewhere. I oiled them all but it made no difference, I think it may be from the belt but I don't know how to increase the tension on the belt.

I would be grateful to hear if you have solved it.

Tiny

holdergt

June, 5, 2010 AT 4:52 PM

YOU HAVE TO CHANGE THE FRONT DRIVE SHAFT I HAD THE SAME PROBLEM

Tiny

holdergt

June, 5, 2010 AT 4:53 PM

Change it before it break and you hit the tranmission

Please login or register to post a reply.

Engine Oil Change and Filter Scion xD
Brake Pad/Rotor Replacement - Front
Serpentine Belt Replacement Mercedes Benz ML