1999 Land Rover Discovery 2 Runs Rough

Tiny
XANGOTED
  • MEMBER
  • 1999 LAND ROVER DISCOVERY 2
Engine Performance problem
1999 Land Rover Discovery 2 V8 Four Wheel Drive Automatic

Starts fine - idles fine - out of gear I can increase the RPM and it runs smooth.

In gear at about 25 mph and up - under load - (acceleration)- we get a vibration almost like a misfire.
If I let off the gas it stops.
Vehicle will coast with no vibration - only vibrates on acceleration.

Engine light came on -
We got codes that the forward Oxy sensors were slow to respond.
We have had also had codes for #3 and #5 misfires and now #6 and #8.

We have replaced plugs, tested wires, replaced forward oxygen sensors.

After replacing Sensors we still have vibration on acceleration but have been driving it for 5 days approx 300 miles and NO engine light. But still have vibration.
Do you
have the same problem?
Yes
No
Friday, April 23rd, 2010 AT 3:40 PM

3 Replies

Tiny
MHPAUTOS
  • EXPERT
Hi there,

Change the fuel filter and take a sample of fuel, draw it off and let it sit in a glass jar, check for water or other contaminates, start here.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Friday, April 23rd, 2010 AT 4:08 PM
Tiny
XANGOTED
  • MEMBER
There is no serviceable fuel filter on a 1999 Disc II V8.
So that idea did not work.
Was this
answer
helpful?
Yes
No
Wednesday, May 19th, 2010 AT 6:47 PM
Tiny
MHPAUTOS
  • EXPERT
There will be a connection at the fuel rail on the engine, undo that connection.

Mark
Was this
answer
helpful?
Yes
No
Wednesday, May 19th, 2010 AT 6:54 PM

Please login or register to post a reply.

Sponsored links