2008 Jeep Wrangler Battery

Tiny
BDH2021
  • MEMBER
  • 2008 JEEP WRANGLER
  • 6 CYL
  • 4WD
  • MANUAL
  • 34,000 MILES
I have to jump start my vehicle to start it. All the power works, lights, radio etc, just clicks when I turn the key, will run fine once its started, but need to jump it again if it is turned off for 10 to 20 minutes. Is this a problem with the altenator, or is it just the battery?
Do you
have the same problem?
Yes
No
Sunday, December 13th, 2009 AT 4:11 AM

4 Replies

Tiny
BLACKOP555
  • EXPERT
Battery issue due to itll start right up if vehicles been off less then 20 minutes. Its discharging. May be a component drawing off of it and not even the battery
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 6:59 PM
Tiny
KJNEWK
  • MEMBER
I am going through the same thing with my 08 Jeep Wrangler. I had to buy a carry around battery boost to get through the week before I can bring it to the dealer. They initially said there was nothing wrong on the first two visits but this third will be it. I want a complete check over including a real test of the alternator and a new battery. The Jeep will start sometimes but there are other times it will not resulting in the jump start which turns the engine over in seconds. After that the vehicle runs fine. I will repost once I hear what the issue is ealry next week. It goes in the shop Friday.
Was this
answer
helpful?
Yes
No
Tuesday, December 15th, 2009 AT 1:34 PM
Tiny
KJNEWK
  • MEMBER
Also, my jeep has 21k miles and is a 2 door 4 whele drive Sahara in case you are trying to match up issues and types. Like the other poster I also believe it is the battery. In addition, jsut today the check engine light decided to come on. The technicians keep stating the battery is fine, but I finally explanied of course it will be fine if I drive to the dealership and charge it up -- so they are keeping it overnight and I hope it does not start for them. In any case I am under warranty for whatever comes up. I will post the outcome.
Was this
answer
helpful?
Yes
No
Tuesday, December 15th, 2009 AT 1:42 PM
Tiny
KJNEWK
  • MEMBER
Hello, if you are still out there I have heard back from the dealership. Turns out my issue is a bad Wireless Control Module. This particualr module controls umong otherthings the starting of the car. Go figure. In any case the part has been ordered and I hope to ahve my Jeep back tomorrow or Monday. Good luck.
Was this
answer
helpful?
Yes
No
Friday, December 18th, 2009 AT 1:04 PM

Please login or register to post a reply.

Recommended Guides