2003 JEEP LAREDO ELECTRICAL PROBLEMS

  • Tiny
  • AXT0KTR
  • 2003 JEEP LAREDO

Electrical problem
2003 Jeep Laredo 6 cyl Two Wheel Drive Automatic 74500 miles

I have been having some elecrical problems with my Jeep. A week ago the radio went out and my dash lights and odometer started blinking. It went away for a few days and then just two days ago I went to get back in my car after just driving it an hour earlier and it would not crank and no lights would come on. I had to jump start it to get it going. I had the Battery checked and it came back as fully charged with no deffect. I don't know what could be wrong. Please assist. Thank you

Do you
have the same problem?
Yes
No
Tuesday, February 17th, 2009 AT 10:25 AM

2 Replies

  • Tiny
  • JDL
  • EXPERT
  • 16,287 POSTS

Hello, I'm not sure of the litre size of your engine, 4.0?

Are the battery cables/wires in good shape on both ends, clean? There should be a starter relay in the power distribution center under the hood. You can unplug the relay, use a test lite, two of the terminals should be hot, with the key in the crank position. Any testing, make sure the tranny is in park or neutral. Let us know.

Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 10:58 AM
  • Tiny
  • AXT0KTR
  • MEMBER

The cables are clean and in good shape. I will try to test that relay switch and get back to you.

Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 11:05 AM

Please login or register to post a reply.

Other Dashboard Light Stay On Questions