99 Jeep Grand Cherokee clicking noise under the console

Tiny
PAPAWNMAMAW
  • MEMBER
  • 1999 JEEP CHEROKEE
I have a 99 jeep grand cherokee larado.4X4 6cyle. Auto. I just had a crankshaft posion sensor put in my jeep. After putting about 25 miles on my jeep, it started making a clicking noise when you hit the brake or when making a turn without hitting the brake. It sounds like it is coming from under the dash. I had someone take the dash out and they said the noise was coming from the trasmision cable they could feel the cable and it felt like it was coming from it. I'm a woman so it is hard to tell. I also had a neighbor look at it and he said he had never heard anything like it before. Any help, PLEASE Thanks Everybody
Do you
have the same problem?
Yes
No
Monday, October 1st, 2007 AT 1:45 PM

2 Replies

Tiny
ANTSMOM
  • MEMBER
I'm getting that same noise when braking or turning, except I just spent $1900 on a new transmission at AAMCO for my 2000 Jeep GC Laredo. The noise was not happening when I originally took the Jeep in for transmission work, so I took the Jeep back to AAMCO and they had it for another week and still could not figure out how to resolve the clicking noise in the console. It really sounds like the noise is coming from under the shifter (or behind the ashtray area).

Now AAMCO suggests that I take it to the dealer. But why should I have to spend more money at the dealer?

Did you ever resolve your clicking noise? Was it a transmission cable?
Was this
answer
helpful?
Yes
No
Saturday, October 20th, 2007 AT 9:35 PM
Tiny
ROBKER
  • MEMBER
There is a cable that routes through the floor or your car just under the dash and goes to the 2Hi / 2Lo level. This cable was rubbing on something becauseI I could feel the cable vibrating when I was braking. You can get to the cable because it is exposed just under the front console from the drivers side.
I brought my Jeep grand cherokee 99 into the dealer and My service advisor said they had to reroute the drive cable but I don't think he understood what the service guy did because later I asked the service guy and he said he found a gromet was loose on this cable going into the transfer case. Since then everything works fine
Was this
answer
helpful?
Yes
No
+3
Thursday, December 13th, 2007 AT 5:37 AM

Please login or register to post a reply.

Recommended Guides