1992 Jaguar Vanden Plas oil pressure issue

Tiny
SHAWNCANADA
  • MEMBER
  • 1992 JAGUAR VANDEN PLAS
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 14,200 MILES
Hello I have a slight issue. My oil pressure is fine for about the first 20 minutes then at an idle in gear it starts to go down. I just changed the oil and its a little better. If you let it run for around 45 min. At 1,000 rpms it has around 20 lbs but if you give it more rpms it goes up to 50 now if you have it in gear it will bounce in and out of the red. Im not sure were the sending unit is or if that is even an issue the motor seems to be running fine no noises or smoke. Could this be a sending unit issue or do you think its an oil pump issue or oil pump screen it doesnt make sense to me cause it has 50lbs at 2000 or higher rpms if it may be the sending unit were is it located thanks.
Do you
have the same problem?
Yes
No
Sunday, January 11th, 2009 AT 11:07 AM

1 Reply

Tiny
DAVE H
  • EXPERT
ENGINE LUBRICATION SYSTEM
A rotor-type oil pump draws oil from oil pan and delivers it under pressure to main and connecting rod bearings. An adapter block is fitted between cylinder block and oil filter housing, which diverts oil flow through oil cooler before filtering. The intermediate shaft, auxiliary shaft and camshaft bearings are pressure lubricated by an oil pas-sageway in front of main oil gallery.
Was this
answer
helpful?
Yes
No
Friday, November 27th, 2009 AT 5:51 AM

Please login or register to post a reply.

Recommended Guides