Rattling or tumbling around noise coming from under the truck

Tiny
HIPPIECHIC
  • MEMBER
  • 1997 CHEVROLET TRUCK
  • 5.3L
  • V8
  • 4WD
  • AUTOMATIC
  • 160,000 MILES
I started hearing a noise coming from under the truck, like something was rattling or tumbling around. Could not pin point it since it is hard to drive and be under the truck so I removed the differential cover to make sure nothing had broken there. It was all good no metal shaving, so replaced the gasket and bolted it back on. Then some said I had a bad bearing and since I had not replaced those I pulled both rear axles out and replaced the bearings. All the u-joint look good and I cannot turn the driveshaft with my hand. So after replacing the bearings it seemed that the noise was more toward the front and I started getting a loud noise after starting and letting it run for a few minutes. The noise sounded to me like the noise you get when a heat shield comes loose. Anyway when I drive it, it will drive fine and then it stops advancing, like I am pressing on the gas but it is not going. If I stop the truck and put it in park and turn it off and then restart it and put it in gear then it will go again. Then after eight or ten blocks it does the same thing again and I have to stop and put it in park and turn it off and restart it. Could it be the inside of my catalytic converter causing this? Stuck.
Do you
have the same problem?
Yes
No
Wednesday, September 21st, 2016 AT 12:36 PM

7 Replies

Tiny
SATURNTECH9
  • EXPERT
Yes I was thinking about a cat that has broken loose inside the whole time when I was reading your description of the noise. When the noise is present take a piece of wood and jar the car around and lightly tap on it. See if it rattles.
Was this
answer
helpful?
Yes
No
Thursday, September 22nd, 2016 AT 4:55 PM
Tiny
HIPPIECHIC
  • MEMBER
Ok thanks I'm gonna go ahead a try my next fix.
Was this
answer
helpful?
Yes
No
Thursday, September 22nd, 2016 AT 10:47 PM
Tiny
SATURNTECH9
  • EXPERT
Keep us posted.
Was this
answer
helpful?
Yes
No
Friday, September 23rd, 2016 AT 7:12 AM
Tiny
HIPPIECHIC
  • MEMBER
Ok well unfortunately after removing the cats and replacing with straight pipes I still have that noise that sounds like a heat shield rattling and after going 6 or 7 blocks the truck stops pushing forward. Once I stop and put it in park and turn off the key. Then I restart the truck and put it in drive it will go again for another 6 or 7 blocks before I have to stop and turn it off again, RRRrrr very frustrated please let me know of what other solutions you might have.

Thanks,

Hippiechic
Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2016 AT 7:57 AM
Tiny
SATURNTECH9
  • EXPERT
So have you checked for codes in the computer yet?It sounds like the computer might be putting it in limp mode.
Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2016 AT 10:36 AM
Tiny
HIPPIECHIC
  • MEMBER
Well thanks for all your advice in my attempts to resolve the issues with my pickup. Unfortunately my hopes of it being something other than the transmission failed. It was the tranny. Something inside the tranny broke apart so I had to replace the tranny after all. On the upside also got other items replaced in my endeavor of not wanting it to be the tranny. And I should be grateful in a way cause those trannies usually only last for about 170,000 and I am at 254,000. Thank you again you guys are always a big help. Till my next adventure.
Was this
answer
helpful?
Yes
No
Monday, December 12th, 2016 AT 9:50 AM
Tiny
KEN
  • ADMIN
Glad you could get it fixed please use 2CarPros. Com anytime we are here to help

Best, Ken
Was this
answer
helpful?
Yes
No
Monday, December 12th, 2016 AT 9:57 AM

Please login or register to post a reply.

Recommended Guides