Information display cluster not working properly

Tiny
FENWAYFAN81
  • MEMBER
  • 2013 NISSAN PATHFINDER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 80,000 MILES
Hello,

My wife’s car is having a issue with the information display cluster between the tachometer and speedometer. It won’t turn on, also any of the steering wheel controls won’t work either. I have tried a reset by unhooking the battery but no joy. I tried using a ANCEL AD310 Classic Enhanced Universal OBD II Scanner and doesn’t show anything. I am lost at this point and could really use some help. Thank you in advance.
Do you
have the same problem?
Yes
No
Saturday, January 9th, 2021 AT 9:08 AM

6 Replies

Tiny
KASEKENNY
  • EXPERT
This is most likely a fuse issue for the cluster issue. So let's check fuse 65 in the fuse and relay box. I show the fuse below.

If there are no fuse issues then I suspect the cluster has failed and will require replacement. I think the steering wheel controls not working is a separate issue but let's address the cluster first because they are an input to the information display.

Take a look at the last attachment which will help explain why I suspect this information display is the issue (integrated into the cluster) is because each of these systems is an input to the display for it to display. If it is not working at all then as long as it is getting power then it would leave the cluster.

Take a look at this info and let us know what questions you have. Thanks
Was this
answer
helpful?
Yes
No
Sunday, January 10th, 2021 AT 2:28 PM
Tiny
FENWAYFAN81
  • MEMBER
Hi, and thank you for the reply. 65 on my wife s car is for the inverter fuse. I did however check all the 10 amp fuses in there. I don t know if this matters but her is the Platinum Edition and the three main fuse boxes are on the right of the car.
Was this
answer
helpful?
Yes
No
Sunday, January 10th, 2021 AT 3:49 PM
Tiny
KASEKENNY
  • EXPERT
Take a look at this picture. Is this the inverter fuse that you are talking about that I circled? If so, I don't show a different fuse box option but clearly the manual is not matching your vehicle. However, the idea is still going to be the same. If we have no blown fuses and the information display does not work then the cluster is going to be the issue.
Was this
answer
helpful?
Yes
No
Monday, January 11th, 2021 AT 6:48 PM
Tiny
FENWAYFAN81
  • MEMBER
I wouldn t suppose you have a part number for me to order a new one? I am searching the web and I can t seem to be finding that exact display. Thanks
Was this
answer
helpful?
Yes
No
Wednesday, January 13th, 2021 AT 3:42 AM
Tiny
FENWAYFAN81
  • MEMBER
Would this work you think?
https://www.ebay.com/itm/2013-NISSAN-PATHFINDER-PLATINUM-3-5L-SPEEDOMETER-GAUGE-CLUSTER-24810-3KA0A-/274637394448?_trksid=p2349624.m46890.l49292
Was this
answer
helpful?
Yes
No
Wednesday, January 13th, 2021 AT 3:50 AM
Tiny
KASEKENNY
  • EXPERT
That should work but it is a different part number then what is listed for your vehicle. I listed the part number below from the manual. Plus the OEM price is over $1,000.00, so clearly that doesn't mean much but the fact that this one is less then $100.00 is a little concerning. However, it seems like worth a shot.
Was this
answer
helpful?
Yes
No
Thursday, January 14th, 2021 AT 7:18 PM

Please login or register to post a reply.

Sponsored links