I keep blowing out my ICM Module

Tiny
AT WHITS END
  • 1999 CHEVROLET BLAZER
  • 4.3L
  • V6
  • 4WD
  • AUTOMATIC
  • 160,000 MILES

I was driving home from work, and car shut down. I towed it home. I found after testing The ICM failed. I replaced the module. And it started I took it for a test drive it seemed ok but while excellerating it died out and would not start. It has a new delco fuel pump and maintains 60 psi. I re tested and found again no spark further investigation I find ICM is failed again. What Could be causing the ICM's to fail?

Do you
have the same problem?
Yes
No
Sunday, December 1st, 2013 AT 10:41 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,362 POSTS

You may have gotten a bad module. Have you tried another to see if it made a difference?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Sunday, December 1st, 2013 AT 11:50 AM
Tiny
CJ MEDEVAC
  • EXPERT
  • 9,701 POSTS

JA PUT SOME OF THAT WHITE HEAT DISSIPATING COMPOUND ON THE BACK OF IT WHEN YOU INSTALLED IT?

THE MEDIC

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Sunday, December 1st, 2013 AT 4:39 PM
Tiny
AT WHITS END
  • MEMBER

Yes I have Replaced it 2x and used the compound on the back both times. I did not want to change it again unless I find cause of failure. @ $70 a shot getting expensive.

Was this
answer
helpful?
Yes
No
Tuesday, December 3rd, 2013 AT 9:53 AM

Please login or register to post a reply.

Related Engine Computer PCM Replace/Remove Questions

Help us by donating