2001 Hyundai Tiburon my car died :(

  • 1 POST

Engine Mechanical problem
2001 Hyundai Tiburon 4 cyl Front Wheel Drive Automatic 80,000 miles

yesterday, I was driving to work
(i went less than 15 miles, most of it freeway, going about 70-80mph)

i got on the ramp for my exit and my car just DIED!

Just turned off, and the check engine light lit up, and the temperature guage shot all the way up to hot.

Well, I had to get to where I could pull over, so I started it back up, drove a couple feet, it shut off again, and I repeated this until I was safely to the side of the road.

There was no smoke, no bad smell, checked the oil, it's good, checked all the fluids, they're all good.

It was making an awful clunking sound when I tried to re-start it.

Tow truck brought it back to my house, it was dark already so we couldn't look too much into it, but when I started it back up to drive it the rest of the way into my driveway, it wasnt making the noise anymore. It's still making a little bit of a noise, but not loud like it was.
And my bf checked the spark plugs, just to make sure that wasn't the reason for it dying, and they were fine, but after he put them back, the check engine light went back off.

Now (i'm not driving it, it's just sitting in my driveway) it's not making that bad of a sound, but it is making a sorta clicking sound, and when I turn it back off, it like. Something squeaks to a stop.

Do you
have the same problem?
Saturday, November 15th, 2008 AT 2:48 PM

1 Reply

  • 1 POST

I had a similar issue turned out to be the water pump, it was about a year or so ago it made a weird noise when it was idleing or under 2k rpm but it seemed fine until the temp gauge would be normal and then just shoot all the way up. Thats what the problem was for me. About 6 months later I had a problem with the car overheating again but it just turned out to be a hose.

Was this
Wednesday, November 26th, 2008 AT 9:05 PM

Please login or register to post a reply.

Recommended Guides