2004 Hyundai Santa Fe Please help

Tiny
SPARKINGWIGGLES
  • MEMBER
  • 2004 HYUNDAI SANTA FE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 86,000 MILES
I have an 04 Santa Fe that ran great. One day going up a big mountain @ 55 mph it spit & sputtered & dropped to 25 mph. Since, then it has not ran right. It feels like I'm driving a 4cyl. What it does now is driving a long @ 55 mph & try to accelerate the engine revs to 4000 rpm's & mph stays the same. I even had the gas pedel to the floor & the rpms went up & the engine made noise but the speed remained the same. The check engine light is not on & is not producing any codes. Have checked the air filter - clean, air hoses - all tight. Please help, thank you
Do you
have the same problem?
Yes
No
Thursday, June 26th, 2008 AT 11:17 AM

3 Replies

Tiny
KHLOW2008
  • EXPERT
Hi sparkingwiggles,

Is any gear downshifting felt when you floored the accelerator?

Did you check the spark plugs?
Was this
answer
helpful?
Yes
No
Thursday, June 26th, 2008 AT 3:38 PM
Tiny
SPARKINGWIGGLES
  • MEMBER
There wasn't any gear downshifting felt.

I had new sparkplug wires last year.
Was this
answer
helpful?
Yes
No
Friday, June 27th, 2008 AT 6:53 AM
Tiny
KHLOW2008
  • EXPERT
Hi sparkingwiggles,

Check the plugs to see if any is not firing well. If the engine is running with lack of power, the trans would not work well.

You need to check the ignition coils, fuel filter and TPS.
Was this
answer
helpful?
Yes
No
Friday, June 27th, 2008 AT 7:26 AM

Please login or register to post a reply.

Recommended Guides