HVAC blower not working

Tiny
ELI012456
  • MEMBER
  • 2003 CHEVROLET 1500
  • 5.7L
  • V8
  • 4WD
  • AUTOMATIC
  • 190,000 MILES
Blower not working at any setting. Replaced with new one. Still not working. Wires to blower have 8 volts even with ignition off. Also ac compressor will only kick in if I use the defrost button but not with the ac button. Can this be the the controls.
Do you
have the same problem?
Yes
No
Tuesday, December 10th, 2019 AT 3:44 PM

7 Replies

Tiny
KASEKENNY1
  • EXPERT
Do you have an auto system or manual controls? Based on your statement I am assuming you have an auto system. If this is the case, it could be the module.

However, this could also be the blower motor processor. If you look at the wiring diagram the HVAC module tells the processor what to do by adding a load to the ground side of the blower motor. By doing this is decreases the voltage that the blower motor uses which slows down the motor.

Can you tell me where you measured this voltage? Looking at the diagram you should have voltage there because the blower is hot at all times. This is a ground side control so the motor will not turn on until the module grounds the circuit.
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 11th, 2019 AT 3:51 PM
Tiny
ELI012456
  • MEMBER
I tested voltage on purple wire going to motor. The voltage was 8 volts. I stated voltage even with ignition off but it did slowly decrease over a short time.
Was this
answer
helpful?
Yes
No
Wednesday, December 11th, 2019 AT 4:38 PM
Tiny
ELI012456
  • MEMBER
It is an auto system.
Was this
answer
helpful?
Yes
No
Wednesday, December 11th, 2019 AT 4:39 PM
Tiny
KASEKENNY1
  • EXPERT
Okay. Just check to make sure the ground is good by checking continuity to ground. I suspect it is fine but we need to make sure. If this is okay, then I suspect the control module is your issue.
Was this
answer
helpful?
Yes
No
Wednesday, December 11th, 2019 AT 4:57 PM
Tiny
ELI012456
  • MEMBER
Okay.I will check the ground. Can't get to it until the weekend.I will let you know what I find. I have been thinking it is the controls.
Was this
answer
helpful?
Yes
No
+1
Thursday, December 12th, 2019 AT 11:45 AM
Tiny
ELI012456
  • MEMBER
You were a big help. Got it working. You have me enough info to track down now to test the climate control module. And after testing that out as ok the only thing left was the blower control module. Replaced that and all works fine. Thank you for your help.
Was this
answer
helpful?
Yes
No
Sunday, December 22nd, 2019 AT 6:59 PM
Tiny
KASEKENNY1
  • EXPERT
Awesome. Thanks for the update. I am sure that info will help others that have this issue. Glad I was of some assistance. It is very typical that we can get you close but you are the ones that fix these things. Good work. Hope you come back to 2CarPros next time you need assistance. Thanks
Was this
answer
helpful?
Yes
No
Monday, December 23rd, 2019 AT 7:27 PM

Please login or register to post a reply.

Sponsored links