1990 Honda Prelude Screeching sound either PS pump or Alter

Tiny
TIMH0722
  • MEMBER
  • 1990 HONDA PRELUDE
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 150,000 MILES
Everytime I start my Prelude now, this awful screeching sound comes from the area of PS pump or Alternator. If you push the throttle down it goes away. Stopping ignition and restarting, sound comes back, always give it a little gas, sound goes away. Time for a PS pump or Alternator or?
Do you
have the same problem?
Yes
No
Thursday, August 27th, 2009 AT 1:39 PM

3 Replies

Tiny
IMPALASS
  • CERTIFIED MECHANIC
Hello -

To better assist you is your model the 2.0 S, 2.0 Si, or Si? Also what is your engine size in liter?
Was this
answer
helpful?
Yes
No
Thursday, August 27th, 2009 AT 2:02 PM
Tiny
TIMH0722
  • MEMBER
I have a Prelude SI 2.0 1990 4 cylinder w/fuel injection
Was this
answer
helpful?
Yes
No
Thursday, August 27th, 2009 AT 2:15 PM
Tiny
IMPALASS
  • CERTIFIED MECHANIC
Hello -

Thanks for the info

Based off of what you are saying I believe your belt is loose. First we can try to tighten it a little but it may need to be replaced.

On the pic below. . .. . .the green circles - these are the bolts to the alternator. If looks like you only have 2. . .but please look really good as they need to be loosened some to allow the alternator to move.

Once loose. . .then the red circle is the belt adjusting bolt. Tighten this until you have about inch depression where the red arrow is. Then tighten the alternator bolts.

Fire it up and let's see what we hear. . ...


https://www.2carpros.com/forum/automotive_pictures/248015_Picture1_48.jpg



Let me know what you find out.
Was this
answer
helpful?
Yes
No
Thursday, August 27th, 2009 AT 3:36 PM

Please login or register to post a reply.

Sponsored links