Have a 94 Pontiac Firebird sputters and idles fast

Tiny
M_H_RITZEL
  • EXPERT
  • 1994 PONTIAC TRANS AM
  • 59,000 MILES
My wifes firebird a v 6 has a problem while on the way shopping it started to buck as if running out of gas. Has fuel and replaced the fuel filter. Took it to garage and they have had it over a month. Sometimes it does it and sometimes not. One day they actually had it so it bucked. There are no codes. The garage says they replaced a couple of sending units and it was fixed. Picked it up and it was all right for a day then started to do the same thing. Back to the garage. They like to make sure things are bad before they replace them. The got a aftermarket computer to see if it was in that. With the aftermarket computer it runs but does not show any speed on the speedometer. They checked with dealer to get it reprogramed but dealer says because of age they do not do it. So the problems I am wondering about is where I can get another computer if that is the problem that matches the car. It is a v-6 with a 5 speed transmission, electric windows and door locks and cruise control everything else is more standard for the car. The main problems when it all started was it sputtered when driving even when accelerating. Then it idles high Around 2300. Would it be in the computer? Mike Ritzel.
Do you
have the same problem?
Yes
No
Tuesday, April 23rd, 2013 AT 8:16 AM

8 Replies

Tiny
ASEMASTER6371
  • EXPERT
They got the replacement and now they need to replace it again as it is defective. It is not your issue but theres/

as far as the running, did they check the fuel pressure?

Roy
Was this
answer
helpful?
Yes
No
Tuesday, April 23rd, 2013 AT 4:39 PM
Tiny
M_H_RITZEL
  • EXPERT
Roy, the garage tried another computer. They are very reliable and do not replace uneccessary parts. We have dealt with them on different occassions. The thing is that it does not do it all the time. Now the problem with the computer they tried, the speedometer is off by 10 mph. Put the old one back in and the car engine runs fast. They called a gm dealership and talked with the service manager and he said that they do not reset those computers as the car is a 94. There are no codes that come up. My wife got in touch with gm and they were surprised that the dealer would not reprogram the computer. The garage is still working on what is wrong. And still don't know.
Was this
answer
helpful?
Yes
No
Wednesday, April 24th, 2013 AT 10:48 AM
Tiny
ASEMASTER6371
  • EXPERT
94 had no reprogramming at all. In fact there is no such program. Your prom contains all the needed info

first the speedo did not work, now 10 miles off? Please calify as you made conflicting statements on that

Roy
Was this
answer
helpful?
Yes
No
Wednesday, April 24th, 2013 AT 4:29 PM
Tiny
M_H_RITZEL
  • EXPERT
I did make a mistake with that. With the old computer, the car would feel like it was running out of gas a few times, this happen iratic since when the fuel pump goes it just stops. They put another aftermarket computer in it to see if it would make a difference. With that computer in it the speedometer was off by 10 mph when driving.
Was this
answer
helpful?
Yes
No
Wednesday, April 24th, 2013 AT 7:47 PM
Tiny
M_H_RITZEL
  • EXPERT
Roy You say it is the prom. Just found out my wife was told is that the spedo is stuck at 10mph. Where can we get a prom?
Was this
answer
helpful?
Yes
No
Monday, April 29th, 2013 AT 8:37 AM
Tiny
M_H_RITZEL
  • EXPERT
So the saga continues. They put the old icm and prom back in the car. Worked all right for a short time. Meanwile I had gotten one that matched up with drive train and engine options. Worked all right until my wife went to go shopping, did the same thing with missing and idling fast. The car now sits in the garage to try to figure out why it does it. Note, that each time the battery is disconnected and hooked back up it runs fine for a while then does the same thing. Thinking about replacing the throttle body.
Was this
answer
helpful?
Yes
No
Monday, June 10th, 2013 AT 7:21 AM
Tiny
M_H_RITZEL
  • EXPERT
Well came out with the answer, had good fuel pressure, computer was Ok, It came out to be the screen in the gas tank, With the ethenol it will clog up the fuel pressure screen. When you first check the fuel pressure it would be all right, but drive the car some and the ethenol would make particles that have settled in the tank to stir up and clog the screen. Replaced the fuel pump, screen and float for the gas guage and the car works fine.
Was this
answer
helpful?
Yes
No
Tuesday, October 28th, 2014 AT 12:32 PM
Tiny
M_H_RITZEL
  • EXPERT
With all the computer changing as the car would go and stop then go. Took it to a friend who had a garage, since the fuel guage did not work properly we changed it. Found that the screen on the fuel pump was clogged because of the ethenal they put in the fuel. The car does sit for months at a time. Just showes that there are other things that would make the car do it.
Was this
answer
helpful?
Yes
No
Tuesday, March 3rd, 2015 AT 2:30 PM

Please login or register to post a reply.

Recommended Guides