Hard Start and Code PO302 and PO352 the Escort is a ZX2

Tiny
WAJESKEY
  • MEMBER
  • 2003 FORD ESCORT
  • 109,000 MILES
Checked for spark at # 2 cylinder good, Checked for injector pulse no pulse checked power side on injector connector good. Checked ground pulse side nothing. Also the car starts very hard also had PO352 in system. Can you help me out?
Do you
have the same problem?
Yes
No
Wednesday, July 10th, 2013 AT 5:50 PM

11 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
P0351 Ignition Coil Primary A / Secondary Circuit Malfunction

That doesn't seem like the problem. If you only have a pulse on the power side of the injector plug, It sounds like you have a ground issue. Are you using a noid light to check for the pulse or a test light? You do realize there shouldn't be a pulse from the ground, correct?
Was this
answer
helpful?
Yes
No
Wednesday, July 10th, 2013 AT 7:19 PM
Tiny
WAJESKEY
  • MEMBER
Sorry I worded it wrong no pulse on number 2 at all. I'm using a test light.
Was this
answer
helpful?
Yes
No
Thursday, July 11th, 2013 AT 3:25 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If you are using a test light, where are you seeking a ground from?
Was this
answer
helpful?
Yes
No
Thursday, July 11th, 2013 AT 7:51 PM
Tiny
WAJESKEY
  • MEMBER
I'm just jumping across the injector connector one end on the red wire and the ground on the white wire.
Was this
answer
helpful?
Yes
No
Friday, July 12th, 2013 AT 4:25 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If you are using a test light, try using the ground on the battery to see if there is power there. You may just have a weak ground at the injector plug.
Was this
answer
helpful?
Yes
No
Friday, July 12th, 2013 AT 7:45 PM
Tiny
WAJESKEY
  • MEMBER
Yes there is power there what's next?
Was this
answer
helpful?
Yes
No
Saturday, July 13th, 2013 AT 10:04 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Now that we know there is power to the injector, there has to be a problem with ground. Trace the ground wire and check for damage.
Was this
answer
helpful?
Yes
No
Saturday, July 13th, 2013 AT 8:39 PM
Tiny
WAJESKEY
  • MEMBER
Doesn't the ground wire go to the power control module so if I check the wire and it is Ok the power control module is bad?
Was this
answer
helpful?
Yes
No
Sunday, July 14th, 2013 AT 11:00 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Try making a new ground to see if that changes anything. You could have a broken wire.
Was this
answer
helpful?
Yes
No
Sunday, July 14th, 2013 AT 8:17 PM
Tiny
WAJESKEY
  • MEMBER
Checked the ground wire from the PCM connector to the injector connector good. Then that means it has a bad PCM correct.
Was this
answer
helpful?
Yes
No
Monday, July 15th, 2013 AT 5:54 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If you have confirmed all wiring is good and nothing is corroded and or damaged, then I would have the PCM tested.
Was this
answer
helpful?
Yes
No
Monday, July 15th, 2013 AT 8:33 PM

Please login or register to post a reply.

Recommended Guides