Grit/pebbles

Tiny
CAJUNGUY1965
  • MEMBER
  • 1995 CHEVROLET S-10
  • 2.2L
  • 4 CYL
  • 2WD
  • MANUAL
  • 204,000 MILES
My 1995 Chevy s10 has a vaccumm pump which plugs into main air intake cover over the throttle plate. There is 4 holes. Two smaller and two larger. One of each is on the left of throttle plate the other two is on the right of throttle plate. I removed the air intake cover and cleaned carbon build up using carburator cleaner. I thought I had the problem solved. While driving the engine stalls. The larger hole only on the right of throttle plate had some grit/pebbles like inside the hole. I cleaned hole and could go a few more miles before stalling again. It looks like this is coming from where tps is. The only place I couldn't clean to well. How do I clean this thoroughly and properly?
Do you
have the same problem?
Yes
No
Friday, January 22nd, 2016 AT 8:55 PM

15 Replies

Tiny
HMAC300
  • EXPERT
Try cleaning your egr passages and clean iac hole as well. Then check hoses for breaking apart.
Was this
answer
helpful?
Yes
No
Saturday, January 23rd, 2016 AT 7:41 AM
Tiny
CAJUNGUY1965
  • MEMBER
I have changed cps, fuel pump&filter, tps, iacv, oil pressure switch, cleaned throttle body and plate. The only thing not changed is vaccumm pump harness as and fuel pump regulator. Still having same trouble. Two vaccumm lines that goes to egr and fuel pressure regulator are broken. What can do this?
Was this
answer
helpful?
Yes
No
Wednesday, January 27th, 2016 AT 3:05 PM
Tiny
HMAC300
  • EXPERT
Old lines can break, grit from pcv if line was bad, excessive heat, maybe wrong type of tubing this is vacuum schematic for a 4.3L tbi hopefully it is correct
Was this
answer
helpful?
Yes
No
Wednesday, January 27th, 2016 AT 3:17 PM
Tiny
CAJUNGUY1965
  • MEMBER
Mine is a 2.2ltr. 4 cylinder. There was grit in one of the "blow holes" where vaccumm pump plugs in. Would broken plastic vaccumm lines cause this? And is it possible for truck to get vapor locked like the older models did
Was this
answer
helpful?
Yes
No
Wednesday, January 27th, 2016 AT 3:42 PM
Tiny
HMAC300
  • EXPERT
No it won't vapor lock because of electric fuel pump. Broken plastic would do it though here is correct one
Was this
answer
helpful?
Yes
No
Wednesday, January 27th, 2016 AT 4:58 PM
Tiny
CAJUNGUY1965
  • MEMBER
I have replaced vaccumm pump harness. My truck ran fine. I drove it down the road. It didn't give any problems. When I got home I let it run a few minutes then it started doing same thing. Everything is cleaned out except EGR valve. What else could give all this trouble I am having? Someone please help
Was this
answer
helpful?
Yes
No
Wednesday, February 3rd, 2016 AT 4:09 PM
Tiny
HMAC300
  • EXPERT
Check fuel pressure with a gauge auto parts rent it and then can scan for codes as well while there.
Was this
answer
helpful?
Yes
No
Wednesday, February 3rd, 2016 AT 4:20 PM
Tiny
CAJUNGUY1965
  • MEMBER
I have inquired about scanning truck. No one has proper plug for OBD 1 system. They can scan from 1996 and newer.
Was this
answer
helpful?
Yes
No
Wednesday, February 3rd, 2016 AT 5:33 PM
Tiny
HMAC300
  • EXPERT
Cross A & B on connection under dash with a paper clip turn key on watch check engine light and count flashes. They will flash in series of three. 3-1's is 1 then 3-2's that mean 12 and so on if you only get 12 then verything is ok
Was this
answer
helpful?
Yes
No
Thursday, February 4th, 2016 AT 5:47 AM
Tiny
CAJUNGUY1965
  • MEMBER
Ok. Thanks
Was this
answer
helpful?
Yes
No
Thursday, February 4th, 2016 AT 1:23 PM
Tiny
CAJUNGUY1965
  • MEMBER
I cleaned EGR passages and entire vaccumm system. Truck ran fine for a couple hours then started doing same thing. I inquired at advanced auto parts and autozone about scanning truck. It has an OBD 1 system. No one can scan for trouble codes. It has me very much puzzled
Was this
answer
helpful?
Yes
No
Thursday, February 4th, 2016 AT 6:10 PM
Tiny
CAJUNGUY1965
  • MEMBER
I cleaned EGR passages and EGR valve. It ran fine for a couple hours (a lot longer than it did before) then started doing same thing. I checked for vaccumm leaks and broken lines. When carburator cleaner is sprayed in throttle body it does like it ganna die. That's normal. After a few sprays it doesn't do anything. It stays running normal.
Was this
answer
helpful?
Yes
No
Thursday, February 4th, 2016 AT 6:17 PM
Tiny
HMAC300
  • EXPERT
I hae no further suggestions to fix your problem unless you say it's fixed.
Was this
answer
helpful?
Yes
No
Friday, February 5th, 2016 AT 7:00 AM
Tiny
CAJUNGUY1965
  • MEMBER
Where would the camshaft position sensor be located on a 1995 Chevy s10 with a 2.2 ltr engine? I am still having trouble with the truck. The only thing I have not changed is camshaft position sensor
Was this
answer
helpful?
Yes
No
Monday, February 8th, 2016 AT 4:48 PM
Tiny
HMAC300
  • EXPERT
You don'thave a cam sensor on that truck. I have no further comments
Was this
answer
helpful?
Yes
No
Tuesday, February 9th, 2016 AT 6:15 AM

Please login or register to post a reply.

Recommended Guides