2002 GMC Envoy 4WD Problem

Tiny
STARK187
  • MEMBER
  • 2002 GMC ENVOY
2002 GMC Envoy w/ 90,000 miles. It has a switch that has 2WD, AWD, 4HI and 4LO. The problem is that I put it in AWD when we had a recent stretch with snow. It warmed up and I put it back in 2WD. Now it makes a very ugly noise, usually when slowing down or accelerating. I can put it back into AWD and the noise goes away. No noise present in 4HI or 4LO either. Any ideas?
Do you
have the same problem?
Yes
No
Friday, January 12th, 2007 AT 11:53 AM

2 Replies

Tiny
JACK42
  • MEMBER
Sounds like a transfer case problem. Could be its not completely disengaging and thus you get the noise. Those transfer cases are a little more complex than a standard one, I suggest you take it to a shop with experience in the AWD cases
Was this
answer
helpful?
Yes
No
Friday, January 12th, 2007 AT 12:54 PM
Tiny
MATHIASO
  • MEMBER
Noise problems are more difficult to diagnose and service than mechanical failures.
Before taking the transfer case to specialist, check if the hub on the opposite side of the axle is not desengaging. That can happend when dirt and water enter the hub and contaminate the lubricant.
If noise comes from transfer case, check for incorrect tire inflation or tire size, excessive tire wear,
It many different transfer cases in used today and each has its own features characteristic and servivce procedure. Proper diagnostics and service beging with the proper indentification of the transfer case.
Like Jack said from the begining, take it to spesialists.

Good luck
Was this
answer
helpful?
Yes
No
-1
Saturday, January 13th, 2007 AT 10:20 AM

Please login or register to post a reply.

Recommended Guides