1994 GMC K1500 4X4 Transmission Problems

Tiny
ECLIPS2LUV
  • MEMBER
  • 1994 GMC C1500
I just replaced the transmission filter
for maintence, now the trans will not shift out of 2nd gear. I dropped the pan and found the filter
had fallen out. I then replaced the the filter and
o-ring again. I got it to stay in pretty good but a few
days later, it wouldn't shift again. Are there any
trouble shooting tips or what is the best way to install the o-ring? Haven't had any transmission problems before I put in the new filter.
Do you
have the same problem?
Yes
No
Saturday, December 16th, 2006 AT 4:54 PM

4 Replies

Tiny
MATHIASO
  • MEMBER
Be sure that you used the right ATF. For example if F fluid is used in a transmission designed for dextron-type fluid, the shifting will be harcher.

Start the engine and allow it to idle for at least one minute. With the parking and service brake applied, move the gear selector momentary to each position ending in park.
Recheck the fluid level and add to the level to about 1/8 inch below the add.
# On transmissions with a governor, after starting the engine, move quickly the gear selector to reverse
by quickly placing the transmission in reverse, the chance of dirt entering the governor is greatly decreased
Run the engine until it reachs normal temperature, then recheck it again.
Was this
answer
helpful?
Yes
No
Saturday, December 16th, 2006 AT 10:42 PM
Tiny
ECLIPS2LUV
  • MEMBER
Thanks for the advice. I will try that. I did use dextron-type fluid. I am going to check tomorrow to see if the filter has popped off again.
Was this
answer
helpful?
Yes
No
Saturday, December 16th, 2006 AT 11:27 PM
Tiny
JACK42
  • MEMBER
That an l60E? The filter in those requires a little love tap with your hand to seat in the valve body. The filter shoulkd be parallel to the valve body if its in all the way
Was this
answer
helpful?
Yes
No
Sunday, December 17th, 2006 AT 8:21 AM
Tiny
ECLIPS2LUV
  • MEMBER
I use all the advice above and dropped the pan today. The filter was in place and was parallel. I started the truck and did as instructed by Mathiaso. The automatic trans shifted smooth but after the truck warmed up it wouldn't shift up from 2nd gear. I guess I will need a Trans expert to look at it. I pretty much plan on having to replace the transmission. It has very high mileage. Just can't figure out why it just start doing this after I changed the filter with no pre-existing problems.
Was this
answer
helpful?
Yes
No
Sunday, December 17th, 2006 AT 1:42 PM

Please login or register to post a reply.

Recommended Guides