1993 Geo Storm rough idle

Tiny
DDGIRL1980
  • MEMBER
  • 1993 GEO STORM
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 145,000 MILES
I have recently had the spark plugs, and wires, and distributor cap replaced also the throttle body has been recently cleaned out yet the car still idles roughly but only when the engine is warm what could be the problem?
Do you
have the same problem?
Yes
No
Monday, April 21st, 2008 AT 3:46 PM

2 Replies

Tiny
JUSTALUCKYSHOT
  • MEMBER
Ah, Yes, My 90 Geo Storm 2+2 does PRECISELY the same thing.

Ive had expert mechanics look at it, and everyones baffled.

First off, we pulled the valve cover, set the valve clearance, checked for stuck valves. Nothing. Clean as a whistle.

Then we tested the TPS, works to a T.

Then we swapped O2 Sensors, which helped, but didnt solve my problem.

We then adjusted Ignition timing, which also helped.

What I suggest doing, swap a new Idle Air Control valve in there, AND, flush the motor, I suggest seafoam.

THEN, clean the injectors. Even if it doesnt fix this problem, it will always help. =D

Hope I helped
Was this
answer
helpful?
Yes
No
Friday, September 19th, 2008 AT 9:22 AM
Tiny
JUSTALUCKYSHOT
  • MEMBER
Just got it outta the shop again. The IAC didnt help. The timing is still right, yet it still has this problem.

Ign timing seems to up itself when the AC is on, and it makes the idle smooth out. But when we advance the ign timing to where the AC knocks it up to, its no better.

Somewhere along the line, something engages with the AC button, along with the IAC racing, and the timing upping. Whatever THAT thing is. ITS the problem.
Was this
answer
helpful?
Yes
No
Monday, September 22nd, 2008 AT 2:38 PM

Please login or register to post a reply.

Recommended Guides