1996 Geo Prizm STALLED WHILE DRIVING 70

Tiny
BHASTICK
  • MEMBER
  • 1996 GEO PRIZM
Engine Performance problem
1996 Geo Prizm Automatic 113000 miles

MY CAR DIED AND we had no spark my husband changed the coil now it starts but it is surgeing when you try to drive it please what else would be causing surgeing while driving only happens under pressure I have had a new timing belt put in new plugs and wires
Do you
have the same problem?
Yes
No
Wednesday, December 3rd, 2008 AT 9:17 AM

7 Replies

Tiny
MMPRINCE4000
  • EXPERT
Have the PCM scanned at any autoparts store for free, look for any error codes or pending codes.

Check fuel pressure with a mechanical gauge, if low you may need a new filter or pump.
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 9:30 AM
Tiny
BHASTICK
  • MEMBER
I HAVE A CODE CHECKER ITS NOT TROWING A CODE I JUST BOUGHT A NEW IGNITER MODULE HOP ETHIS FIXES IT KINDA AT ALOSS
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 10:37 AM
Tiny
MMPRINCE4000
  • EXPERT
Could be a bad ignitor, you should be able to get the old one checked at most autoparts stores for free.

Check the cap for cracks and make sure the rotor is not worn out.

Also when you buy the ignition module, check the price of a remanufactured or new dist. Vs. The cost of the ignition module itself, checking parts stores, the complete dist. With a module is cheaper than the module itself (4AFE 1.6 engine).

So take the module back and get the complete dist.

How much did you pay for the ignitor?
Was this
answer
helpful?
Yes
No
Friday, December 5th, 2008 AT 6:37 AM
Tiny
BHASTICK
  • MEMBER
Changed the igniter and still sputters when push gas we have changed the dist and wires and the coil changing the coil now it runs but what could have burned out the old one. It is not trowing a code we have a code checker but nothing is showing we dont know what to do im on disability and cant afford a garage please anything
Was this
answer
helpful?
Yes
No
Friday, December 5th, 2008 AT 6:59 AM
Tiny
BHASTICK
  • MEMBER
Was this
answer
helpful?
Yes
No
Sunday, December 7th, 2008 AT 8:46 AM
Tiny
BHASTICK
  • MEMBER
WE HAVE REPLACED ALL THE SENSORS AND THE PLUGS AND WIRES NEW CAPAND ROTOR STILL SPUTTER WHEN PUSHING GAS I HAVE SPENT ALOT OF MONEY PLEASE HELP
Was this
answer
helpful?
Yes
No
Sunday, December 7th, 2008 AT 8:48 AM
Tiny
MMPRINCE4000
  • EXPERT
Check the fuel pressure with a mechanical gauge.

Inspect the fuel pressure vacuum line for the presence of gas. If there the FPR diaphram is ruptured and must be replaced.
Was this
answer
helpful?
Yes
No
Sunday, December 7th, 2008 AT 8:54 AM

Please login or register to post a reply.

Recommended Guides