SPEEDOMETER

1993 Geo Prizm

Tiny

marlenny

January, 10, 2008 AT 1:33 PM

Other Category problem
1993 Geo Prizm 6 cyl Front Wheel Drive Automatic? Miles

THE SPEEDOMETER ON MY 93 GEO PRISM STOPPED WORKING WHEN TAKE OFF FROM A STOP IT WILL ONLY SOMETIMES REGISTER UP TO 30 OR 40 MPH AND WHEN YOU LET OFF THE ACCELERATOR IT WILL START MOVING UP AND WHEN YOU ACCELERATE IT WILL GO BACK DOWN TO 0 MPH.

FOUND 3257 RELATED QUESTIONS

Erratic Speedometer

9 ANSWERS
7 IMAGES

Speedometer

32 ANSWERS

3 Answers

Tiny

mmprince4000

January, 19, 2008 AT 9:46 AM

It is probably the lower cable (they used a two piece mechanical cable at least until 1992).

The lower cable screws into the transmission, it will get worn over time and slip, stop working, or break.

You can still get them from Toyota, or go to a junk yard.

It could also be the plastic gear in the transmission the drives the cable. This is accessible after removing the cable.

The speedometer gauge itself could be bad also.

Tiny

mooretw52

June, 25, 2009 AT 3:48 AM

I doubt if it's the cable(s) More like a sensor problem. The guage itself would register incorrectly, if the guage was bad, but it wouldn't move up if you let up the gas. Could be your computer, too. (Ouch!) Didn't know Prizms had a 6 cylinder option < g>

Tiny

mmprince4000

June, 25, 2009 AT 8:20 AM

They may have switched to a VSS (speed sensor) in 1993 (not sure). Look at connection on trans. If there is a cable on top of trans below intake, then cable, if an electrical connection then VSS.

Please login or register to post a reply.

Instrument Cluster Replacement GMC Yukon
Coolant Temperature Sender Replacement
Cabin Air Filter Replacement
Cabin Air Filter Replacement Porsche 911