2000 Geo Metro High Idle

Tiny
BLUCHERB
  • MEMBER
  • 2000 GEO METRO
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 107,000 MILES
This is a problem that is getting worse by the day. It is two problems, but I think they might have to deal with each other. First when I get in and start the car in the morning, the engine will idle like it is warm, not the higher idle that I am use to it doing until the engine has warmed up. Then after I start driving the car and come to a stop, the engine will be idling higher than normal. Sometimes it will go away after the next stop light I stop at, or I will shut the car off and turn it back on and most the time it will idle normal, until I come to the next stop light. The engine was surging up and down at one stop light, but hasn’t done it sense. Here is what I have done to try to fix the problem.

I have taken apart the throttle body, disassembled it and cleaned it. I have taken off the Throttle Position sensor from the throttle body while it is still connected to the ECM and the check engine light comes on (so I think the sensor is working, could still be bad though) I have done the same with the MAS and with the Idle Air Control Valve that is located on the throttle body. The Check engine light will come on when I disconnect them all and the engine will still be idling high. So I think the sensors appear to be good to the computer, but im thinking one is bad. The MAS will effect the idle some when I pull it out or disconnect it, but I think that’s normal. Its Hard to decide which one to buy fist considering there a couple hundred a piece. Thank you for your help.

Brad
Do you
have the same problem?
Yes
No
Thursday, January 8th, 2009 AT 4:09 PM

2 Replies

Tiny
RASMATAZ
  • MEMBER
Lets try the idle air control valve again

Here's how to clean the IAC valve:

Disconnect the air intake ductwork from the throttle body.

Start the engine, then increase and hold the idle speed to 1,000 to 1,500 rpm.

Spray the throttle cleaner or engine cleaner into the throat of the throttle body, aiming for the idle air bypass port (usually located on the side or top of the throttle body opening). Give this area a good dose of cleaner (about 10 second's worth).

Turn the engine off to allow the cleaner to soak into the IAC passageway.

Wait about three minutes.

Restart the engine, rev and hold at 1,000 to 1,500 rpm, and repeat the cleaning process again.

Turn the engine off again, and reattach the air intake ductwork to the throttle body.

Start the engine and rev and hold to 1,500 to 2,000 rpm until no white smoke is coming out of the exhaust pipe.

If this fails to make any difference, you can remove the IAC valve from the throttle body and spray cleaner directly on the tip of the valve and/or into the ports in the throttle body. Let the cleaner soak awhile, repeat as needed, then reinstall the IAC valve, start the engine and run it at 1,500 to 2,000 rpm as before until no white smoke is seen in the exahust.

If the idle speed still surges after this, the IAC valve is defective and needs to be replaced.
Was this
answer
helpful?
Yes
No
+1
Thursday, January 8th, 2009 AT 4:42 PM
Tiny
RASMATAZ
  • MEMBER
Too fast an idle speed. If an engine without computerized idle speed control is idling too fast and refuses to come down to a normal idle speed despite your best efforts to back off the carburetor idle speed screw or air bypass adjustment screw (fuel injection), air is getting past the throttle somewhere. Common leak paths include the carburetor and throttle body gaskets, carburetor insulator spacers, intake manifold gaskets, and of course, any of the engine's vacuum fittings, hoses and accessories. It is even possible that leaky O-rings around the fuel injectors are allowing air to leak past the seals. Another overlooked item can be a worn throttle shaft and a defective idle speed speed control motor/valve stuck in the extended (high idle speed) position/throttle position sensor. Also the throttle plate could be binding in its bore and kinked accelerator cable, coolant temperature sensor might not be operating properly misleading the computer that the engine is still cold and computer throwing fuel at it raising the idle speed
Was this
answer
helpful?
Yes
No
+1
Thursday, January 8th, 2009 AT 4:47 PM

Please login or register to post a reply.

Recommended Guides