Fuel gauge not working. Fuel indicator lamp ON.

Tiny
BENDOR
  • MEMBER
  • 2007 GMC YUKON
  • 5.3L
  • V8
  • RWD
  • AUTOMATIC
  • 150,350 MILES
Fuel gauge pointer not going up. Always in zero. Fuel indicator lamp is ON. Fuel tank is full. We replaced fuel level sensor with new original GM parts. But the gauge still not working.I removed ECM and put another ECM from other car which is working good, still fuel gauge not working. Before doing so, we checked it with scan tool, No DTC found. We did not replace yet the meter cluster assy. Since it is more expensive, yet we are not sure if the problem is in the meter cluster itself. We checked the two wires from fuel level sensor to ECM it is good. Any help pls. Thank U.
Do you
have the same problem?
Yes
No
Monday, March 28th, 2016 AT 12:13 AM

3 Replies

Tiny
JOHNNYT73
  • EXPERT
With a good scan tool, you should be able to do a cluster sweep of all the needles on the cluster. If the needle does not move when doing the sweep then the cluster needs to be changed, or sent out for recalibration. Be sure to write down your milage.
Was this
answer
helpful?
Yes
No
+1
Monday, March 28th, 2016 AT 6:00 AM
Tiny
BENDOR
  • MEMBER
Yes we did a cluster sweep of all the needles. All the needles are are working and the fuel lamp indicator goes off. But when I start and run the engine only the fuel gauge is not working, the other gauges are working good. The milage is 128522. The car is GMC Yukon 2007. V8 5.3L. Thank U so much for your reply.
Was this
answer
helpful?
Yes
No
-1
Tuesday, March 29th, 2016 AT 6:22 AM
Tiny
KEN
  • ADMIN
It sounds like it could be the BCM I have attached the fuel gauge operation description
Was this
answer
helpful?
Yes
No
Monday, April 4th, 2016 AT 1:43 PM

Please login or register to post a reply.

Sponsored links