Fuel gauge not working

Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
  • 2003 CHEVROLET VENTURE
  • 127,000 MILES
The fuel gauge is not working. It has a new fuel pump and sending unit and this did not help the problem.
Do you
have the same problem?
Yes
No
Monday, April 25th, 2016 AT 10:33 AM

18 Replies

Tiny
HMAC300
  • EXPERT
Check to see if power is going to gauge, it may be the dash as they are digital and will do that. It may need a stepper motor in dash
Was this
answer
helpful?
Yes
No
Monday, April 25th, 2016 AT 11:55 AM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
Okay I will check that I will let you know. Thanks
Was this
answer
helpful?
Yes
No
Tuesday, April 26th, 2016 AT 7:51 AM
Tiny
KEN
  • ADMIN
If the fuse is good the problem is probably the gauge gauge cluster. We use a place in Brea California called AER you can UPS it to them for a rebuilt unit to fix the problem.
Was this
answer
helpful?
Yes
No
-1
Tuesday, April 26th, 2016 AT 8:29 AM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
I checked the fuse and the gauge cluster they are all good I am unsure what to check now. I do have my engine light come on from time to time with an emissions control code could that have anything to do with it
Was this
answer
helpful?
Yes
No
-1
Wednesday, April 27th, 2016 AT 4:53 AM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
And I check all the fuse but is there one just for the fuel gauge and if so where would it be?
Was this
answer
helpful?
Yes
No
+1
Wednesday, April 27th, 2016 AT 4:58 AM
Tiny
HMAC300
  • EXPERT
It would be for all gauges so if other ones work it's not the fuse
Was this
answer
helpful?
Yes
No
Wednesday, April 27th, 2016 AT 7:18 AM
Tiny
KEN
  • ADMIN
Did you find out anything else out more about this problem?
Was this
answer
helpful?
Yes
No
Thursday, April 28th, 2016 AT 8:01 AM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
No my fuel gauge is the only thing not working when you start the van it goes all the way to full and stays there for a few seconds the goes to empty and stays there I am unsure what to check next
Was this
answer
helpful?
Yes
No
+2
Thursday, April 28th, 2016 AT 12:42 PM
Tiny
HMAC300
  • EXPERT
Normally when that happens it s' a grounded wire at tank or sending unit. But because yours is all one unit in tank it gets expensive. You also have a micro processor in dash unit so either can be doing it. It is a yellow/wht wire at tank and dash so you see if power is going there while still plugged in or going to it.
Was this
answer
helpful?
Yes
No
Thursday, April 28th, 2016 AT 1:14 PM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
OK I will check this next so it's a yellow and white wire that runs from the tank to the dash
Was this
answer
helpful?
Yes
No
+1
Friday, April 29th, 2016 AT 2:12 AM
Tiny
HMAC300
  • EXPERT
Yes
Was this
answer
helpful?
Yes
No
Friday, April 29th, 2016 AT 6:42 AM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
We are going to redrop the fuel tank this week hopefully we can figure something out when we do this
Was this
answer
helpful?
Yes
No
Sunday, May 1st, 2016 AT 4:03 AM
Tiny
HMAC300
  • EXPERT
All you need do is disconnect it before dropping tank if gauge stays at full then it may be a short but if drops then it may be sender
Was this
answer
helpful?
Yes
No
Sunday, May 1st, 2016 AT 8:16 AM
Tiny
KEN
  • ADMIN
I followed the wiring for you and the sender feedback signal goes straight into the main PCM computer. So if the pump sender doesn't help the computer itself may be bad, here are the wiring diagrams.
Was this
answer
helpful?
Yes
No
Monday, May 2nd, 2016 AT 10:57 AM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
We haven't had a chance to drop the tank yet but we tracked the wires and there isn't a yellow and white wire in any of the wires in the dash or to the tank. The only time it goes to full is when you first start the van other than that it stays at empty I don't see how it could be the sender in the tank as it is in the third fuel pump because we changed the first one hoping it would fix the fuel gauge that didn't work and the fuel pump went out a month later so they sent us another new one and it is put in I don't see 3 fuel pump sending units all being bad
Was this
answer
helpful?
Yes
No
Monday, May 2nd, 2016 AT 11:00 AM
Tiny
KEN
  • ADMIN
I just talked to my guy at Chevy and he agrees with Hmac300 its the stepper motor for the gauge, you can find one here

http://www.amazon.com/Partsam-x27-168-Instrument-Cluster-Stepper/dp/B00KWQTCX8/ref=sr_1_2?ie=UTF8&qid=1462309288&sr=8-2&keywords=chevy+gauge+stepper+motor

They even give you instructions on how to install them.
Was this
answer
helpful?
Yes
No
Tuesday, May 3rd, 2016 AT 2:02 PM
Tiny
MELINDA N WILLIAM LEDFORD
  • MEMBER
I already checked the stepper motor and put another one in and it is still doing the same thing not sure what else to check
Was this
answer
helpful?
Yes
No
Wednesday, May 4th, 2016 AT 2:35 AM
Tiny
KEN
  • ADMIN
The only thing left is the main PCM computer, that what I would try next.
Was this
answer
helpful?
Yes
No
Wednesday, May 4th, 2016 AT 7:53 PM

Please login or register to post a reply.

Recommended Guides