Fuel gauge and left side of tach won't light up with rest of interior lights

Tiny
2002GTP40THANNIVERSARY
  • MEMBER
  • 2002 PONTIAC GRAND PRIX
  • 3.8L
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 155,503 MILES
I just bought the car and found out that some of the bulbs were burnt out in the dash so I went about replacing them, everything is working now except my fuel and tach backlighting. I took the bulb out (farthest to the left illumination bulb) and replaced it, even bent the bulb contacts in the socket so as to make for a good connection with the bulb, and even bent the ears for the socket down so they can get a good contact on the back of the cluster. I even tried switching sockets with another in the system so I know the socket isn't bad but I'm running out of ideas, the only thing I haven't tried is to just have the cluster rebuilt but I don't think that its worth 40 buck just to fix a light. Especially since everything else in the cluster works perfectly.
Do you
have the same problem?
Yes
No
Saturday, July 26th, 2014 AT 10:14 AM

2 Replies

Tiny
HMAC300
  • EXPERT
It's probably either the cluster or a body module problem and I dont'think it 's the module.
Was this
answer
helpful?
Yes
No
Saturday, July 26th, 2014 AT 10:32 AM
Tiny
2002GTP40THANNIVERSARY
  • MEMBER
I think I may have found my solution I just hardwired the sockets together with some spare wire I had lying around the house. I've just tied them altogether to see if it would work and it did. Just need to make it permanent. I will be soldering the sockets and wires later to make it permanent.
Was this
answer
helpful?
Yes
No
Monday, August 4th, 2014 AT 3:29 PM

Please login or register to post a reply.

Recommended Guides