2004 Ford Thunderbird Is it a faulty fuse or a short?

Tiny
PEABODYJR
  • MEMBER
  • 2004 FORD THUNDERBIRD
  • V8
  • 2WD
  • AUTOMATIC
  • 45,800 MILES
Driving my T-Bird to Maine, I noticed that the left/right blinkers did not work. Then noticed that lights did not turn on properly. With headlights on, when I tried to turn on left or right blinker it instead turned on high beams. I could not engage emergency flashers and when I parked car, fog lights or head lights would not turn off, even with switch in the off position.
Fuses seem OK, but I have had to disconnect battery to turn off lights and the reminder beep.
Car was running fine and had recently undergone major service.
Only major change was that I put the hard top on to make the drive. Could that in some way upset the electrical? If not any ideas?
Many Thanks
Do you
have the same problem?
Yes
No
Thursday, November 5th, 2009 AT 1:30 PM

4 Replies

Tiny
MATHIASO
  • MEMBER
Hello peabodyjr

No sir, the hard top did not upset the electrical.

Are the following lamps working?

LAMP ASSEMBLY, LEFT REAR
SIDE LAMP RIGHT REAR
SIDE LAMP LEFT REAR
LICENCE LAMPS
LICENCE ASSEMBLY, RIGHT REAR.

*Let me know if all of those are working.

There are controlled by the rear electronic module, independant from the front.
Was this
answer
helpful?
Yes
No
Thursday, November 5th, 2009 AT 5:23 PM
Tiny
PEABODYJR
  • MEMBER
Dear mathiaso
Yes sir, all those lights are working. In fact, they remain on even when I have removed the key and turned the light switch to off! It's weird
Was this
answer
helpful?
Yes
No
Friday, November 6th, 2009 AT 8:17 AM
Tiny
MATHIASO
  • MEMBER
You should test the switch.
if the switch is good then we can move forward to test the front electronic module.
let start with switch:
I'm sending multifunction testing procedure.
if the switch pass all the test then the module is nest.


http://www.2carpros.com/forum/automotive_pictures/46384_mutiswitch__small_1.jpg



sending the same in your email
Was this
answer
helpful?
Yes
No
Friday, November 6th, 2009 AT 6:23 PM
Tiny
MUSTANGMARK
  • MEMBER
I have a t-bird 2002 48K miles, when I open the door all the warning lights on the dash or cluster turn on, and the steering wheel does not adjust automatically, they are still on while I am driving also, when I shut off the car all the warning lights are still on til 2 minutes later and then they go off.
Any suggestions?
Do I need to test the front electronic module and where is it located. Can you send me the multifuncion testing procedure
Thanks
Was this
answer
helpful?
Yes
No
Tuesday, July 20th, 2010 AT 5:32 PM

Please login or register to post a reply.

Recommended Guides