CAR RUNS ROUGH AFTER WARMING UP

1991 Ford Tempo

Tiny

czicn34

March, 23, 2010 AT 10:09 PM

Engine Performance problem
1991 Ford Tempo 4 cyl Front Wheel Drive Automatic 138000 miles

recently towed a small trailer, started to run real rough, missing and sputtering, could romp on the throttle and it would run but then at idle again would spit and sputter again. Replaced O2 sensor, plugs, wires, cap rotor. Found a small pin hole in the heater bi-pass hose, fixed that and discovered the anti freeze was spraying on the two sensors in the thermostat houseing. So dug into that and replaced thermostat and the bi-pass hose. Car will start and run like a dream. Almost down to the tick, as soon as the car hits operating temp, it will miss and start to spit and sputter and like it won't even get out of its own way.

FOUND 4561 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

1 Answer

Tiny

rasmataz

March, 23, 2010 AT 11:37 PM

Engine running rough or misfiring can be cause by the following: inspect and test all the following below: 1. Defective spark plug.
2. Inadequate spark/coil, defective spark plug wire.
3. Lack of compression
4. False air leakage.
5. Faulty fuel injectors.
6. Insufficient fuel pressure.
7. Contaminated fuel.
8. EGR valve that is leaking.
9. Oxygen sensors.
10. Throttle position sensor.
11. Idle air control valve.

Please login or register to post a reply.

Code Read Retrieval/Clear - Dodge Stratus
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Chevrolet Camaro