2004 Ford Taurus Misfire problems

Tiny
PENNMATTHEWS
  • MEMBER
  • 2004 FORD TAURUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 119,000 MILES
I started having misfire issues a week ago. The engine code came back with a problem in the primary coil. I changed the coil pak and still have the problem. I changed plugs, wires and the camshaft sensor all in an attempt to fix the problem. I am now getting multiple engine codes (random misfire, misfire in first 1000 revolutions, misfire in cylinder 6 and 2).
Yesterday while it was idling as I put in a bottle of injector cleaner I started pulling off wires at the coil to see spark activity and affect it had on the engine while it is running. The number two coil lead did nut put out any spark yet the others visibly did. Any ideas?

2004 Ford Taurus 3.0 not DOHC and not FlexFuel
Do you
have the same problem?
Yes
No
Thursday, October 22nd, 2009 AT 7:15 PM

3 Replies

Tiny
BMRFIXIT
  • EXPERT
I would suspect defective coil
remove and replace coil and let me know
Was this
answer
helpful?
Yes
No
Thursday, October 22nd, 2009 AT 7:22 PM
Tiny
PENNMATTHEWS
  • MEMBER
Sure enough. It was a defective coil from the parts store. Figures the first thing I would change is defective and it led me to replace other parts trying to fix the issue.
Was this
answer
helpful?
Yes
No
Tuesday, October 27th, 2009 AT 5:23 PM
Tiny
JONK777
  • MEMBER
I have a 2005 ford Taurus with the 3.0 motor. Car has 167,000 miles on it. The car idles right. But when you get up to speed, it acts like it wants to blog down.
Was this
answer
helpful?
Yes
No
-2
Tuesday, April 12th, 2016 AT 5:59 PM

Please login or register to post a reply.

Recommended Guides