2002 Ford Taurus Idle Trouble

Tiny
ZZCRITTER
  • MEMBER
  • 2002 FORD TAURUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 100,000 MILES
I have a 2002 Ford Taurus V6 DOHC. About a month ago it was running rough. Took it to a shop and they replaced the fuel pump. After it ran pretty good except a slight miss on startup but after 30 seconds it would be fine. Or if you drove it it ran fine. They could not totally fix it. It always came up on their computer misfire on startup. Then it would go away. They replaced the EGR valve and sensor. They tried a new coil. Nothing totally got rid of the hesitation at startup. It sat for probably a week. Now When I start it up it does not want to idle. I goes down low and jumps around. Even after I drive it when I come to a stop it does the same thing. Sometimes it will die. After 1000 RPM it is fine. Drives fine, accelerates fine. It has codes po171 and po174 lean bank 1 and 2. Also it has a pending code of p0113. Iat sensor 1 ckt high. Have read somewhere it could be a MAF. I don't want to spend the 100.00 if it could be something else. Any help would be appreciated. Thanks
Do you
have the same problem?
Yes
No
Wednesday, May 19th, 2010 AT 8:15 PM

1 Reply

Tiny
BMRFIXIT
  • EXPERT
Possible MAF sensor
most common is a vacuum leak
check PCV valve hose and suspect intake manifold gasket
a smoke test should verify
ask them to do a smoke test before spending the money on a sensor you may or may not need
Was this
answer
helpful?
Yes
No
Wednesday, May 19th, 2010 AT 8:31 PM

Please login or register to post a reply.

Recommended Guides