1999 Ford Taurus

Tiny
CBANKHEAD
  • MEMBER
  • 1999 FORD TAURUS
Engine Mechanical problem
1999 Ford Taurus Automatic 200K miles

My Ford Taurus is really out of whack. It is a 1999, but the engine in it is a 1996.

The speedometer (when it works) bounces around. When the accelerator is applied, it sits on zero, but when the brake is applied, it jumps up to where it should be. It has also starting slipping out of gear on hills and acting up. I assume that is a transmission issue, but could it be anything else?
Do you
have the same problem?
Yes
No
Monday, March 30th, 2009 AT 1:33 PM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Make sure the ATF is full. Also, has the check engine light ever come on?
Was this
answer
helpful?
Yes
No
Thursday, April 9th, 2009 AT 1:06 PM
Tiny
CBANKHEAD
  • MEMBER
Yes, I believe ATF is full, with no leakage issues. My check engine light has been on for the 5 years that I've owned it. Each time it was cleared off, it would come back on within about 15 miles of driving it. I was told by a mechanic that it was probably some debris on the sensor or an 02 sensor issue and not to be concerned about it.

I did speak to a friend regarding my problem, and he suggested that I try replacing the speed sensor again, as it was purchased through O'Reilly's, and he has had a number a bad parts come from there.

What do you think?
Was this
answer
helpful?
Yes
No
Thursday, April 9th, 2009 AT 4:12 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
It won't hurt to try. However, when the check engine light indicates there is a code stored in the computer. The mechanic who checked it should have known exactly what to check and repair based on the code that came up.

Try this. Take the car to a nationally recognized parts store and have the computer scanned again. Ask them what code they find and let me know what they tell you. A speed sensor will set a code too, so that way you will know what you are facing. Also, most of the stores will scan it for free, so there will be no money out of pocket.

That is what I suggest for now. Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Thursday, April 9th, 2009 AT 8:26 PM
Tiny
CBANKHEAD
  • MEMBER
2 codes came up.A speed sensor code and a cylinder misfire code. Replaced the sensor, AGAIN, and am getting new plugs and wires this weekend hopefully. Speedometer still bouncing around and will still get over 3000 RPM before shifting sometimes, just acting up. Am considering replacing the instrument cluster to see if that fixes the speedometer issue.

What's your recommendation? Am I on the right track?

PS, thanks for your help. Lord knows I need it!
Was this
answer
helpful?
Yes
No
Thursday, April 16th, 2009 AT 11:58 AM

Please login or register to post a reply.

Recommended Guides