1996 Ford Taurus Engine barely Idles

Tiny
RETURN2BEACH
  • MEMBER
  • 1996 FORD TAURUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 204,000 MILES
My 96 taurus blew a freeze plug while driving on a divided highway. I heard a ticking noise, the rpm's started to go up, speed went down, and braking became difficult, but the car kept running less than a 1/4 mile to a gas station. I had it towed home, replaced the freeze plug and added antifreeze. Now it rough idles like it wants to die, so I replaced the fuel filter. No heat blows out of the vents when the heater is on. And the air coming from the exhuast is sputtering, no liquid, just air. I did flush the radiator, and there is NOT any water in the oil. What should I do next?
Do you
have the same problem?
Yes
No
Friday, July 23rd, 2010 AT 12:23 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Are you getting any white smoke from the exhaust? Also, have you checked for vacuum lines that may have melted if it got really hot?
Was this
answer
helpful?
Yes
No
Friday, July 23rd, 2010 AT 10:39 PM
Tiny
RETURN2BEACH
  • MEMBER
There isnt any white smoke coming from the exhuast. I havent checked the vaccuum, I really hadnt thought about it. I'll have to get a diagram of the hoses and check them. Thank you, Erica
Was this
answer
helpful?
Yes
No
Saturday, July 24th, 2010 AT 1:36 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Erica:
Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Saturday, July 24th, 2010 AT 11:31 PM

Please login or register to post a reply.

Recommended Guides