1996 Ford Ranger Loss of power

Tiny
SACTOFORD
  • 1996 FORD RANGER

Engine Mechanical problem
1996 Ford Ranger 6 cyl Two Wheel Drive Automatic 157, 00 miles

157,000 My 96 Ranger loses power and the engine shakes when I eccelerate. I've changed the spark plugs, spark plug wires and the fuel filter and it still has these same symptoms. My scan tool shows no codes. All other mainenance has been done on schedule.

Do you
have the same problem?
Yes
No
Saturday, March 28th, 2009 AT 2:20 PM

3 Replies

Tiny
RANGERDANGER17
  • MEMBER

Now that you done the igntion system do the fuel system

then your looking at the fuel pump and injectors

i would try some fuel injector cleaner you put in you gas tank

if its your fuel pump it wont last long the pump will die soon

check your coil packs or distribuator all connection areas should be bright shiney and clean

get back to me if this doesnt help

Was this
answer
helpful?
Yes
No
Saturday, March 28th, 2009 AT 6:28 PM
Tiny
SACTOFORD
  • MEMBER

Checked the coil pack plug connections with younger eyes. The rubber boot was pushed back, not sealing out moisture and the terminals were very corroded. We cleaned them up with electical cleaner and roughed them up as much as possible. The problem has not reoccured so far.

Thanks much for leading me in the right direction.
Sacto

Was this
answer
helpful?
Yes
No
Monday, March 30th, 2009 AT 4:48 PM
Tiny
RANGERDANGER17
  • MEMBER

Your very welcome just glad to help

Was this
answer
helpful?
Yes
No
Monday, March 30th, 2009 AT 6:36 PM

Please login or register to post a reply.

Other Engine Low Power Questions