Alternator Terror

Tiny
GWBROWN
  • MEMBER
  • FORD
I have a 1990 Mercury Topaz, with a 2.3 L engine. Recently, my "AMP" dash light has been blinking on and off, as if it is being triggered by a relay short, or something like it. I have investigated the alternator, and the voltage regulator (which is built into the alternator), but am not sure of what I am looking at. This seems to happen most when all the accessories such as A/C and head lights are off. ANY help from ANYONE would greatly be appreciated.
Thank You!
Do you
have the same problem?
Yes
No
Wednesday, March 29th, 2006 AT 6:19 PM

3 Replies

Tiny
PEPPERMRJ
  • MEMBER
You can have the alt tested very inexpensively. Some shops and auto parts stores will even test it for free in hopes you purchase their services.

Post back with questions/results. :)
Was this
answer
helpful?
Yes
No
Wednesday, March 29th, 2006 AT 7:14 PM
Tiny
RASMATAZ
  • MEMBER
Perform a Regulator By-Pass test and re-observe the Amp lite. That's if you know how. Check the belt and connections between Alty and Battery- and Double check all connections involving the Charge System.
Was this
answer
helpful?
Yes
No
Wednesday, March 29th, 2006 AT 7:24 PM
Tiny
DAVIDCLOOP
  • MEMBER
I have a 1993 Mercury Tracer I had this same problem as it turns out in my case it was only a loose connection at the altenator.
If I were you I would check all your connections at the alt. By unplugging them and check for any loose wires or coroded/ dirty conections. Also look for any wires going to the alt that look to have been streched as this can cause an intermitant connection as well.
Was this
answer
helpful?
Yes
No
Sunday, April 9th, 2006 AT 12:23 PM

Please login or register to post a reply.

Recommended Guides