Mustang repair- HELP!

Tiny
HOOPTY
  • MEMBER
  • FORD MUSTANG
My mustang wouldn't start so I thought it was just a dead battery.I jumped it and was leaving the parking lot and it just died. And now it won't start. The battery is okay because the radio and clock works. Can someone help me!
Do you
have the same problem?
Yes
No
Wednesday, August 23rd, 2006 AT 7:01 PM

7 Replies

Tiny
MIKEYBDMAN
  • MEMBER
I would check the battery cables for corrosion and tightness. I would try a new battery, or a battery barrowed from another vehicle and have a local parts store test your altenator.
Was this
answer
helpful?
Yes
No
Wednesday, August 23rd, 2006 AT 7:08 PM
Tiny
320HPPONY?
  • MEMBER
Like he said! The batt is probably bad because the alternator is shot and the car was running on just the battery for a while. Clock and radio will run on a fairly small amperage so dont think that the batt is still good because of that.I have a battery that only has like 3 cells left that are good and I use it on my lil boat to power the CD player and q-beams, It wont start a car though!
Was this
answer
helpful?
Yes
No
Monday, August 28th, 2006 AT 2:01 PM
Tiny
TCOOPER
  • MEMBER
I would try the alternator. Get it cranked take the battery cable off and if it dies the alt. Is bad or the voltage regulator is bad.
Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2006 AT 8:28 PM
Tiny
HARDMAN
  • MEMBER
The feul filter might be plugged you should replace them every 3rd or 4th oil change there only $6.00 any way and take 5min. To do.
Was this
answer
helpful?
Yes
No
Monday, September 4th, 2006 AT 2:49 AM
Tiny
SACRILIDGE06
  • MEMBER
Check all the ground wires. Then check the ignition module tfi could also be a bad coil.
Was this
answer
helpful?
Yes
No
Wednesday, September 27th, 2006 AT 12:39 PM
Tiny
BUBBA_KOSKI
  • MEMBER
What you said is the alternator, a hint when yoou jump a car off, and it dies when you pull the cables off or within 10min, thats your alternator, I recommend just getting a rebuilt 20 dollar core charge made by palladium or just get new
Was this
answer
helpful?
Yes
No
Thursday, September 28th, 2006 AT 12:03 PM
Tiny
CCM POWER
  • MEMBER
Definitely sounds like the alternator. I had a very similar problem with a car I had a few years back. It did the same thing and when I replaced the alternator everything was fine again.
Was this
answer
helpful?
Yes
No
Saturday, September 30th, 2006 AT 9:47 AM

Please login or register to post a reply.

Recommended Guides