2005 Ford Mustang Idle Surge

Tiny
REEDAWGG
  • MEMBER
  • 2005 FORD MUSTANG
  • V8
  • 2WD
  • AUTOMATIC
  • 50,000 MILES
Recently I added a few things to my car. CL7140 Diablosport Predator (running 93 octane), and C&L cold air kit racer 95 mm. I have contacted Diablo and all they recommend is checking for leaks in the intake. I have checked everything and added silicone as necessary. The idle still surges constantly. When turning on things such as the A/C it's very drastic to a point that the motor almost shuts down. I didn't modify anything on my throttle body whatsoever. Could someone please help me if at all possible? Thanks!
Do you
have the same problem?
Yes
No
Friday, April 24th, 2009 AT 10:45 AM

5 Replies

Tiny
RACEFAN966
  • EXPERT
Ok as a fellow Ford and Mustang enthusiast I would like you to check the PCV system for any cracks in the hose or any leaks in the connections. Then use a spray bottle to check for any intake or throttle body leaks too. Get back to me with what you find and we will go from there. You may need a digital multi meter to do a couple of tests and is the engine light on?
Was this
answer
helpful?
Yes
No
Friday, April 24th, 2009 AT 11:09 AM
Tiny
REEDAWGG
  • MEMBER
Yes the check engine light is on and here are the error codes.
P0506 Idle Air Control System RPM Lower Than Expected
P1000 OBD Systems Readiness Test Not Complete

I have gotten these codes several times after clearing and re-installing the tune. I have also raised the Drive and Neutral Idle Rpm's to see if that helps but it doesn't much. I will try to check everything more in detail this weekend and see if I have much luck. I'm not very knowledgeable on my motor or the mechanics of it yet but starting to learn. Could you possibly explain the PCV system and what I need to do? Thanks!
Was this
answer
helpful?
Yes
No
Friday, April 24th, 2009 AT 12:10 PM
Tiny
RACEFAN966
  • EXPERT
Ok on code P0506 I need you to check the voltage to the Idle Air Control motor. So check the dark blue wire with the yellow stripe or the orange wire with yellow stripe (hard to tell which as there are 6 pages of diagrams to look through just for the engine) for power with a volt meter with the key on engine off.
The P1000 code is because the car is new or the battery has been disconnected or trouble codes have been cleared recently. Let me know what you find and we will go from there.
Was this
answer
helpful?
Yes
No
Saturday, April 25th, 2009 AT 8:04 PM
Tiny
REEDAWGG
  • MEMBER
Earlier I took my intake and throttle body off completely. Cleaned and resealed everything. As of now I have no surge and everything is running fine. Very strange but whatever as long as it's working. Thanks for your help. If something else occurs I'll let you know. :)
Was this
answer
helpful?
Yes
No
Saturday, April 25th, 2009 AT 9:27 PM
Tiny
RACEFAN966
  • EXPERT
Great glad to hear it is running as it should. If you have any more problems for sure get in touch ok. Thanks again and dirve it like you stole it.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2009 AT 7:10 PM

Please login or register to post a reply.

Recommended Guides