2003 Ford Mustang Wipers and Turn Signal

Tiny
MACH1MUSTANG777
  • MEMBER
  • 2003 FORD MUSTANG
  • V8
  • 2WD
  • MANUAL
  • 55,000 MILES
I have a 2003 Mach 1 Mustang. The windshiel wipers and front left turn signal don't work. The fuses and bulbs are good.I replaced the multi function wiper and turn signal switch but it did'nt help. Once in a while the wipers will take off full speed by themselves when the switch is off but I can't turn them on or off.
Do you
have the same problem?
Yes
No
Thursday, April 29th, 2010 AT 8:14 PM

1 Reply

Tiny
MATHIASO
  • MEMBER
Hello mach1mustang777

Welcome to 2carpros

You are dealing with a short to ground, before the grounding switch. (Because there is no blown fuse) or a short to power between connectors. And corrosion in connectors could be the problem.
Before hunting for short, lets check the basics.
In the battery junction box, there are 2 relays:
Wiper high/low relay, wiper park/run relay. check those two.(one of them may sticks)
If the relays are good, on the wiper/low relay side, there are 4 connectors before the wiper motor.( check for corrosion in those)
On the wiper par/run relay side there are 3 connectors before the wiper motor. (Check those) look also for burn wiring insulator on that side.
For the park /turn lamp left front, check the ground as indicated. Check for open between the switch and the bulb.

here is the wiper diagram and its related connectors.


http://www.2carpros.com/forum/automotive_pictures/46384_0996b43f80247957_1.jpg



here is front left turn signal diagram .
Check your email for those 2 diagrams


http://www.2carpros.com/forum/automotive_pictures/46384_0996b43f8024794c_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 30th, 2010 AT 7:26 AM

Please login or register to post a reply.

Recommended Guides