1992 Ford Festiva Car will turn over but not start.

  • 1 POST

Electrical problem
1992 Ford Festiva 4 cyl Front Wheel Drive Manual 99005 miles

Greeting, my car will not start and local mechanics are unable to determine why. There is spark and fuel but apparently there is no "pulse " to the injectors. The car did run great before other that durin the spring before when first starting the car would run rough for 30 -40 seconds until it " warmed" up. Suddenly after a col autumn morning is would turn over but not catch and start. Any answers would be greatly appreciated?

Do you
have the same problem?
Friday, October 17th, 2008 AT 10:17 AM

1 Reply

  • 2 POSTS

I am going to assume that your 92 layout is very close to the 1990 ford festiva.

With that said, I had close to the same issue with my 1990 aside from checking the pulse on the injectors.

What I found was that on the passenger side air box (mass air flow sensor) had a leak in it. It is the square box on top of the air box filter. So first I used some RTV to seal it.

Then I made sure all connections going to the throttle body (Hoses etc.) Were sealed and tight no leaks.

Lastly, something I found rather odd was on the 1990 at least on the driver side against the shock absorber mount there was a small square box with THREE wires to it. All three wire were coated in what looked like an old time woven mesh.

I pulled all three wires, cleaned each connection replaced each wire snugly and sealed it with a cap.

Got in the car, turned the key. Took about 6 tries and it fired right up.

Note: the middle wired connection if not seated right will kill ALL POWER to the electronics. SO you will surely know.

Hope this helps, of course all that was done after making sure timing and everything else was in order as far as I could tell.

Good luck hope it helps. :)

Was this
Friday, November 28th, 2008 AT 2:40 AM

Please login or register to post a reply.

Recommended Guides