A/C compressor runs all the time.

Tiny
MIKE33
  • MEMBER
  • FORD F-350
Hi I have a 1989 E350 motorhome with a 460 engine it has 94500km on it. I had the a/c repaired last year they put the new R134 in it and it was fine but this year I tried it and it blows cold but the compressor run's all the time. It was a hot day and I'm not sure if this is normal for a hot day I always thought they cycled then stopped.
Do you
have the same problem?
Yes
No
Friday, June 29th, 2007 AT 9:30 PM

8 Replies

Tiny
98RANGERXLT
  • MEMBER
Yes this is normal espesially on a hot day once the compressor gets cool enough it will then cycle on and off.
Was this
answer
helpful?
Yes
No
Saturday, June 30th, 2007 AT 12:38 AM
Tiny
MIKE33
  • MEMBER
Thanks fordman16 I will keep an eye on it. I only have one more question. If the compressor still keeps running after it's cool out, does that mean there is something wrong if so what could that be?

Thanks.
Was this
answer
helpful?
Yes
No
Saturday, June 30th, 2007 AT 9:35 AM
Tiny
JWALTH02
  • MEMBER
Not necessarily, it could be hotter inside your engine compartment and it hasn't reached the temperature on the compressor for it to decide to turn off.
Was this
answer
helpful?
Yes
No
Saturday, June 30th, 2007 AT 10:43 AM
Tiny
MIKE33
  • MEMBER
Thanks jwalth02 I just don't want something to happen on our holidays that is going to cost a arm and a leg. I am going to watch this close and make sure it's fine, when I bought this unit the air was not working and I had it fixed and then it stopped again so the same people fixed it again for free, then one more time it stopped every time it was low of freon so you can see my worries. Well I thank you for the time you took bye for now.
Was this
answer
helpful?
Yes
No
Saturday, June 30th, 2007 AT 7:13 PM
Tiny
MIKE33
  • MEMBER
Hi "justanold" the rear one is separate and works fine the front one went about a month apart between fixes, the tech said the last time they found a leak and that should be it they put the R134 in at the last repair. So hopefully that is it. All though I still worry like the compressor running all the time on hot days then on cool days it cycle's in really short breaks like runs for a second then off for a second and on again. Thanks
Was this
answer
helpful?
Yes
No
Saturday, June 30th, 2007 AT 10:13 PM
Tiny
MIKE33
  • MEMBER
Hi. No they didn't all I know is that it was a hard one to find and that it was fixed. The first two times I think they just added freon. Thanks. Mike
Was this
answer
helpful?
Yes
No
Saturday, June 30th, 2007 AT 10:53 PM
Tiny
MIKE33
  • MEMBER
Hi. Sure I'll take your advice if you think it's still leaking. Is that why it is running all the time in hot weather and cycling in and out every second in cool weather? If this is normal then I guess I'm just a causes guy. Thanks justanold

Mike. :D :D
Was this
answer
helpful?
Yes
No
Sunday, July 1st, 2007 AT 1:54 PM
Tiny
MIKE33
  • MEMBER
Hi. Ok I will look at this stuff and get back to you thanks very much justanold.

Mike. :D :)
Was this
answer
helpful?
Yes
No
Sunday, July 1st, 2007 AT 2:43 PM

Please login or register to post a reply.

Recommended Guides