1997 Ford F-150 little or no power at instruments

Tiny
STR8OFAKIND
  • MEMBER
  • 1997 FORD F-150
Electrical problem
1997 Ford F150 V8 Four Wheel Drive Automatic

i'm having trouble starting my truck. The battery is charged and i'v even put a new battery in, but when I turn the key the instrument panel will barely light up and the windshield wipers will barely move. If it were an open fuse I should get no power so i'm thinking maybe something else. Starter has been removed and tested and reinstalled. Starter relay is good. Neutral safety switch is good. I notice when I can get the key to make the starter relay that the positive wire at the battery terminal is very hot. Any suggestions where to look next? Thanks
Do you
have the same problem?
Yes
No
Saturday, August 16th, 2008 AT 10:13 AM

3 Replies

Tiny
MERLIN2021
  • EXPERT
If the cables are hot, there is too much resistance in the circuit, check the condition of the cables, both the + and - pay attention to BOTH ends of the cables! And the cable from the solinoid to the starter. Disconnect the - first and hook it back up last.
Was this
answer
helpful?
Yes
No
Saturday, August 16th, 2008 AT 10:35 AM
Tiny
STR8OFAKIND
  • MEMBER
Any ideas why power is in and out at instrument panel?
Was this
answer
helpful?
Yes
No
Saturday, August 16th, 2008 AT 10:49 AM
Tiny
MERLIN2021
  • EXPERT
If you have a bad ground connection, you might get 50% power, PCM needs 10 volts to operate correctly.
Was this
answer
helpful?
Yes
No
Saturday, August 16th, 2008 AT 11:25 AM

Please login or register to post a reply.

Recommended Guides