XLT V-8 IDLES AT 500 RPM

1997 Ford Explorer

Tiny

whitesa90

September, 4, 2007 AT 1:15 PM

When I start it it starts then goes to 500 rpm or below then stalls out but then I start it again give it gas but then it goes back to 500 rpm then stalls again then I repeat by giving it gas till it warms up then I drive a mile or two then its good the rest of the day. What is the problem with it? And I have read forums about it and they say it happend to them and it the IAC or the camshaft sensor what should I do?

FOUND 4250 RELATED QUESTIONS

5 Answers

Tiny

merlin2021

September, 4, 2007 AT 1:36 PM

Knowing the mileage would help, but try unplggin your MAF and going for a short drive.

Tiny

whitesa90

September, 4, 2007 AT 6:43 PM

It has 161, xxx miles on it

Tiny

merlin2021

September, 5, 2007 AT 6:14 PM

Plenty of miles to ruin a MAF! Test it

Tiny

tv man

October, 18, 2007 AT 6:52 AM

Plenty of miles to ruin a MAF! Test it

How do you test a MAF?

Tiny

merlin2021

October, 21, 2007 AT 7:05 AM

You'll need a scantool you can monitor as you drive...here's the chart! Or just unplug and go for a short ride, if driveability improves, replace it!


http://www.2carpros.com/forum/automotive_pictures/62217_MAF8Cyl_copy_1.jpg



http://www.2carpros.com/forum/automotive_pictures/62217_30961_mitchell_2_59.jpg

Please login or register to post a reply.

Vacuum Leak Test and Repair - All Cars
Read Codes Like a Pro
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Scion XD