1994 Ford Explorer low RPM problem

Tiny
SNOOKY989
  • MEMBER
  • 1994 FORD EXPLORER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 125,000 MILES
When I'm at a stoplight sometimes I hear this light thump and my rpm's drop to about 500 and the engine begins to pulsate for a couple seconds. A couple seconds after that the check engine light comes on. Sometimes it turns off after 10 seconds and other time it stays on for 10 or 15 minutes.

This also occasionally happens on the freeway after I have reeched freeway speed. I will be driving for a while and hear this light thump then my rpms go from 2000, about where they r supposed to be, and go up to about 2500 rpms like it shifts down to the next lowest gear or something. Once again my check engine light comes on for a while and it goes off soon after.

I have hooked it up to a scanner and so far all I t has told me is that my oxygen sensor is reading lean, and insufficient rpm change during system test.

Please help if u know anything. Thank u so much.
Do you
have the same problem?
Yes
No
Friday, January 29th, 2010 AT 11:08 PM

2 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Is it a thump or a knock?

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Monday, February 1st, 2010 AT 8:25 AM
Tiny
SNOOKY989
  • MEMBER
Its a thump like it shifting really hard or something. It slightly jolts the car when I'm on the freeway or at a stoplight. Now it also when the light turs green and I press the accelerator, it doesn't want to go for a second then it takes off after a second.

Thanx for the help, really appreaciate it.
Was this
answer
helpful?
Yes
No
Tuesday, February 2nd, 2010 AT 1:27 PM

Please login or register to post a reply.

Recommended Guides