2000 Ford Expedition

Tiny
LADONNAGE
  • MEMBER
  • 2000 FORD EXPEDITION
  • V8
  • AWD
  • AUTOMATIC
  • 16,512 MILES
I have P0401 egr insufficiant flow. I have changed the egr valve 2 times, I also cleaned the passage out, I am attempting to get a smog test completed. On my scanner it states egr insufficiant flow, but on the computer there states catalyst inc o2 inc, in which I just changed all o2 sensors, all convertors, all spark plugs, & all coil packs, the mafe, pcv system, heavy duty muffler, exhaust pipe and sealed. I do not understand what it could be. The vac. Reg test ok as well. Please help I bought this 4x4 truck aug 2003, drove it the first time 10/31/2003, dec 2003, started my night mare since then 13 rear differentials, 1 front differential, 2 transmissions, 1 shop stole it and damaged the engine by putting a sticky substance in the oil and I had my engine rebuilt. I do not want to give up on it, but I can't pass the smog now.
Do you
have the same problem?
Yes
No
Sunday, July 18th, 2010 AT 7:01 PM

2 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Are you getting good vacuum to the EGR?
Was this
answer
helpful?
Yes
No
Sunday, July 18th, 2010 AT 9:53 PM
Tiny
LADONNAGE
  • MEMBER
Since july 18,2010 I have received 3 codes on the obd. I have changed everything, egr, pcv, 2/3 pcv hoses, dpfe sensor, egr vacuum regulator sensor, vapor management control valve, ignition coils, spark plugs, 4 convertors, muffler, exhaust pipe, 4 o2 sensors
Was this
answer
helpful?
Yes
No
Thursday, September 16th, 2010 AT 3:28 AM

Please login or register to post a reply.

Sponsored links